Results 1 to 2 of 2

Thread: BT5RC3 x64 - Problems installing NVidia GeForce GT540M

  1. #1
    Just burned his ISO
    Join Date
    Jun 2012

    Default BT5RC3 x64 - Problems installing NVidia GeForce GT540M

    Hello all!

    After trying everything I found in other threads here I can't get the correct graphics driver working. Everything I tried didn't lead to goal.
    I think the main problem is the nouveau kernel module which seems not to be able to uninstall or blacklist.
    Latest steps I tried:
    #apt-get install linux-headers-$(uname -r)
    #apt-get install build-essential
    #added following in /etc/modprobe.d/blacklist.conf
       blacklist vga16fb
       blacklist nouveau
       blacklist rivafb
       blacklist nvidiafb
    #edited /boot/grub/grub.cfg
       text splash nouveau.modeset=0 vga=791
    #apt-get --purge remove nvidia-*
    #apt-get --purge remove xserver-xorg-video-nouveau
    The installation seems to finished correctly... After reboot and startx I get an error that no screens were found.

    I will show you my log:

    # lspci -nnk | grep VGA -A2
    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
    00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 [8086:1c3a] (rev 04)
            Kernel driver in use: mei
    01:00.0 VGA compatible controller [0300]: nVidia Corporation GF106 [GeForce GT 555M SDDR3] [10de:0df4] (rev a1)
            Kernel driver in use: nvidia
            Kernel modules: nvidia, nouveau, nvidiafb
    # lsmod
    Module                  Size  Used by
    vmnet                  55665  13 
    ppdev                  17104  0 
    parport_pc             32571  0 
    vsock                  47979  0 
    vmci                   85669  1 vsock
    vmmon                  76074  0 
    nvidia              12348955  0 
    snd_hda_codec_hdmi     31994  1 
    snd_hda_codec_realtek   222503  1 
    snd_hda_intel          33175  2 
    snd_hda_codec         110336  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    arc4                   12529  2 
    snd_hwdep              13554  1 snd_hda_codec
    snd_pcm                92879  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13324  0 
    ath9k                 134009  0 
    snd_rawmidi            29179  1 snd_seq_midi
    uvcvideo               67221  0 
    snd_seq_midi_event     14436  1 snd_seq_midi
    snd_seq                60549  2 snd_seq_midi,snd_seq_midi_event
    psmouse                72820  0 
    mac80211              478885  1 ath9k
    videodev               93508  1 uvcvideo
    snd_timer              28838  2 snd_pcm,snd_seq
    snd_seq_device         14129  3 snd_seq_midi,snd_rawmidi,snd_seq
    v4l2_compat_ioctl32    20896  1 videodev
    acer_wmi               27846  0 
    snd                    64384  14 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    ath9k_common           13604  1 ath9k
    mei                    40623  0 
    soundcore              12598  1 snd
    snd_page_alloc         18101  2 snd_hda_intel,snd_pcm
    ath9k_hw              401846  2 ath9k,ath9k_common
    ath                    22992  3 ath9k,ath9k_common,ath9k_hw
    cfg80211              190023  3 ath9k,mac80211,ath
    sdhci_pci              18683  0 
    sdhci                  31728  1 sdhci_pci
    lp                     17789  0 
    parport                44368  3 ppdev,parport_pc,lp
    serio_raw              13211  0 
    sparse_keymap          13526  1 acer_wmi
    joydev                 17457  0 
    aufs                  183689  0 
    usbhid                 46275  0 
    hid                    97618  1 usbhid
    tg3                   147905  0 
    mxm_wmi                12823  0 
    wmi                    18697  2 acer_wmi,mxm_wmi
    video                  18858  0
    Any suggestions on my problem? After installing BT persistent to my hdd the graphics are worse than after booting from my USB-Stick...

    Thanks for your replies and

    best regards,


  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: BT5RC3 x64 - Problems installing NVidia GeForce GT540M

    Did you enter text mode, stoped the X's before installing and removed the nouveau module loaded by kernel?...

    You do not need to use: apt-get --purge remove, please read "man aptitude"..just aptitude purge "whatever.."..It will remove package and purge config files.

    I do not think you have to black list all those modules, just nouveau...I've done it many times before, even now I'm posting from my Dell 8600 with nvidia card (used the nvidia propietary driver) and I just blacklisted nouveau...It is the module you want to black list. Perhaps and only perhaps, the other modules might cause some problems to some nvidia video card driver, but not all of them. Just be more basic...If it doesnot work, then you can start blacklisting more modules, but one by one...

    Did you enter text mode and stoped the X's before installing?...

    1. Get in text mode and stop the X's. (you pick your method: init 1 or stoping the X's with gdm3 stop)
    2. Uninstall the xserver-xorg-video-nouveau
    3. remove nv module loaded: modeprobe -r nouveau or rmmod nouveau
    4. blacklist nouveau
    5. before start driver installation, change permmissions to file: chmod 777
    Then Install driver from nvidia...(the latest version for your card is: you have an old one...
    6. Restart X's or Reboot..Is up to you. If you stoped the X's with init 1, you need to go back to BT5 default runlevel (2 to 5) and "startx"..You can find the runlevel this way: cat /etc/inittab | grep -i deafault it will return a line like this: id:2:initdefault: So your default runlevel is 2. Now
    just: "init 2" and then "startx"..Again, find the runlevel..The runlevel 2 is for Debian..Find the one for BT5..

    Try it...Hope it helps

Similar Threads

  1. ACER 4755G i5 NVDIA GeForce GT540m Problem.
    By napster719 in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 09-06-2012, 10:21 PM
  2. Bumblebee and nvidia problems with GT540M
    By Dezio in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-22-2012, 12:46 AM
  3. is ther any way to make nvidia gtforce GT540M work on bt5?
    By mesmar in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 03-07-2012, 11:26 AM
  4. nvidia gt540m : i can't get it work
    By jolly in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 03-03-2012, 11:42 AM
  5. nVidia Geforce 8800GT
    By dsync0 in forum OLD BT3beta NON-WORKING HARDWARE
    Replies: 1
    Last Post: 03-31-2008, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts