I have a 2009 Sony Viao VGN-FZ140E computer. Which had windows 7 32 bit installed on it.
I burned a live cd of BackTrack5 and booted from it. From the startx window I used the icon on the desktop to install it to my computer. It did not see my copy of windows on the install (yes this might have clued me in there would be a problem).

So then when booting from the HD it would bring up BT5 and it worked fine.
I used bt5 to get some work done, and then had no way to boot back into windows.

I found a post related to this mistake which gave some info about booting from the livecd and using “gparted” to remove /dev/sda1
But this copy of the cd does not include it. Also I do not know how to get the wifi to work from the bt5 cd (though I know it works, and I have the ssid and key), and I have no cable ethernet access.

I got a windows 7 ultimate 32bit disc and tried to run the windows repair tool. It said that my computer did not have win7 ultimate installed. So now I am unsure of the former version of win 7, but whatever I can start over with the CD I have...

I then tried to install a fresh copy of windows. When it gave me the options to select a partition there were 3 options. None of which would it let me install windows on them. They all had an error which mentioned the drive not being NTFS or being in the GPT format. It would only let me delete the partition with BT5 on it. Which I seem to have done.
The Win7 install would begin to format a drive partition, but never bring up a bar, then after a few seconds would act like I had not clicked on the radio button to do so.

So like I said I think I deleted the bt5 partition, when booting from the HD I get:
error:unknown file system
grub rescue>

I burned a cd of the program Boot-Repair-Disc
and booted it. It wants connection to the internet, to update itself (which I can't seem to make happen).
But it eventually returns the following information:
Boot info Summary
-->Grub2 (v1.97-1.98) is installed in the MBR of /dev/sda and looks at sector 2048 of the same hard drive for core.img. core.img is at this location and looks in partition 2 for /boot/grub.

File system: ntfs
Boot sector type: Windows vista/7: NTFS
Boot sector info: No errors were found in the boot Parameter Block
Operating system:
Boot Files:

File system: swap
Boot sectore type: -
Boot sector info:

Drive/ Partition Info:
Drive: sda______________________________
Disk /dev/sda:80 GB, 80026361856
255 heads, 63 sectors/track, 9729 cylinders, total 156301488
units= sectors of 1 * 512 = 512 bytes
Sector size logical/physical 512bytes/ 512 bytes
partition boot start sector end sector # of sectors System
/dev/sda1 4,096 149,846,015 149, 841, 920 data partition (windows/Linux)
/dev/sda2 149,846,016 159,301,311 6,455,296 data partition (windows/linux)
“blkid” output:

/dev/ loop0 squashfs
/dev/sda1 BCCE3A66CE3A18DA ntfs
/dev/sda2 2dle7fb4-4f34-4335-936d-621f71e493bb swap

mount points:
device mount-point type options
/dev/sr0 /live/image iso9660 (ro,noatime)
The program gives me this info in a text file and says it has made no changes to my computer.

I am not sure as to what to do from here. I would use another computer normally to format the drive. But I have just moved to Europe from California for 9 months and I only have access to a macbook pro or the pc's at the local web cafe (locutorio). I would like a working system on windows 7, any advice that would help me make that happen would be greatly appreciated.