Results 1 to 2 of 2

Thread: BT5R3 Issues with my Dell XPS 14 (dual boot installation)

  1. #1
    Just burned his ISO
    Join Date
    Sep 2012

    Default BT5R3 Issues with my Dell XPS 14 (dual boot installation)

    So, it's been a few weeks that I have been looking all over, read tons of forum post from either Linux websites, Ubuntu, or here (BT) community. I also spoke to 2 of my professors in IT. I am resorting to posting to this website for help, couldn't fix it.

    So I have a Dell XPS 14 ultrabook.
    I'd like to install Backtrack 5 R3 (KDE or GNOME 64) as a dual boot on my laptop.

    The issue I have is that when I open the Installation from my liveCD (that I burned), backtrack doesn't recognize my hard drive or partition!
    However, using sudo fdisk -l
    the liveCD recognize my hard drive.
    I think it is due to my XPS being on RAID0.

    I would like to know what is the fix to a RAID machine to install Backtrack 5, I can provide any hardware information if you guys need some more.

    I read on some Ubuntu 10.04 LTS support forum that that version had an issue with RAID configured machines to install through Ubiquity etc.. :

    "Each Ubuntu release has had it own quirks with regards to installing on a raid. The 10.04 desktop release does come with dmraid which allows you to access your raid (apparently '/dev/mapper/isw_chibcceegh_Volume0'). The quirks are 1)that gparted run from 10.04 will not work on a raid partition and the partitioning step of the installation will fail 2) that the installer will try to install the grub boot loader to /dev/sda and that if this is one of your raid drives, that will fail.

    The workarounds I have used are to:

    1) pre-format (ext2, ext3 or ext4, it doesn't matter) the target partition with an earlier version of Ubuntu, either installed or live cd. The catch is that you must have dmraid installed or install it. This can be done to a live cd session if you have internet capability - gparted will not see the raid or its partitions unless the raid drives are activated by dmraid.

    To install dmraid in a terminal - Code:

    sudo apt-get install dmraid
    To activate the raid - Code:

    sudo dmraid -ay
    You now can start gparted (System>Administration>Gparted or Partition Disks depending on the version your running from) and select an unallocated space to create your target sized as you want it - or resize an existing partition to give you unallocated space in which to create your partition in. You will also have to create a swap partition if there is not already one present. We probably don't have to address it here, but if you already have two or more partitions on this array, you should create additional partitions in an extended partition (you are currently limited to four total primary partitions including an extended partition on any drive). Note the name of this partition. Once your pre-formated partitions is created on the raid you can boot into your 10.04 live cd.

    At this point you pick the desktop icon to start the installation of 10.04. When you reach step 4 of 7 you will pick the option to manually specify the partition you have previously formatted to install to. When step 5 of 8 appears, select your partition and click 'change' at the bottom of the window. In the box select the format from the drop box choices (probably ext3 or ext4, same as what you previously formated). Do NOT check to format. In the next drop down select '/' - the mount point you file system is to be installed to.

    2) To hopefully handle the 2nd quirk, at step 8 of 8 you will click on the box labeled 'Advanced'. At this point you should be able to select the top array name (the name representing the entire array, not one of the partitions) from a drop box. After this you have done everything you can do. You can click next and you system will be setup on the chosen partition. I have just run into the problem in Mint where this was not adequate. The installer still tried to install to sda and resulted in a 'fatal failure'. If this happens don't despair - it can still be fixed. Just continue to install without the boot loader. I will have to research the specific steps and get back to you on this if we have to address it.

    As you can tell, raid in Ubuntu is not for the faint hearted or under informed. It is doable. You will have to do some learning along the way. If you are going to try and stick with it, I or others will be able to help along the way."

    Should I install an older version of Ubuntu and follow the instructions above? or anyone as a different fix for these issues! I tried using a flash usb, a Virtual Machine installation, a liveCD etc... nothing worked, Backtrack installer never "sees" my Hard Drive.

    Thanks everyone for help!!

  2. #2
    Just burned his ISO
    Join Date
    Sep 2012

    Default Re: BT5R3 Issues with my Dell XPS 14 (dual boot installation)

    I finally installed Backtrack 5 R3 on my dell xps 14 by cloning my Windows 7 --> formatting my drive --> removing the RAID0 configuration of my 500 GB HDD and 30 GB mSata --> it now recognized my Hard Drive..

    However, is there a way to reconfigure my RAID0 and still be able to use Backtrack 5 R3 without an issue? Was it only problematic for the installation setup or it will be if I reconfigure it? Thanks

Similar Threads

  1. Dual Boot Installation Question
    By Chaos in forum Beginners Forum
    Replies: 5
    Last Post: 02-06-2010, 02:33 AM
  2. Dell Vostro 1720 boot issues
    By Rextech in forum OLD BackTrack 4 Bugs and Fixes
    Replies: 1
    Last Post: 11-11-2009, 06:06 PM
  3. Pre-Final boot/installation issues
    By Dom.Hutton in forum OLD BackTrack 4 General Support
    Replies: 5
    Last Post: 09-13-2009, 02:17 PM
  4. Dual boot Windows/BT issues
    By scumgiant in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-06-2007, 07:54 PM
  5. After dual boot installation
    By slimo in forum OLD Newbie Area
    Replies: 1
    Last Post: 03-12-2007, 05:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts