I have a Sony Vaio VGN-FZ140E from 2009. It had windows 7 installed on it.
I burned Back Track 5 to a cd and booted from it. ran startx, I then installed BT5 on my harddrive from the link on the desktop of BT5.
during the install it did not notice my other OS. (this should have tipped me off as a problem but I am used to linux and windows ignoring each other. so I let it install.)
So now my computer would only boot into BT5 and not windows. So I got some things done with BT5 and I am ready to try to fix windows to boot again.

first I found some advice about running gparted and removing /dev/sd1 with the live CD version of BT5.
but gparted is not included in this installtion, and I could not get the internet to connect to download it.

So I got a copy of the Windows 7 ultimate DVD. It would not repair the computer as it said it was a different version of the OS than what was installed. I thought that was my OS.
So I told it to install a new copy. It would not, as all 3 partitions were not NTFS but GPT now. So I tried to delete all 3 partitions so that I could start over. It would only delete the partition with bt5 on it. (so now it won't boot either, if I let the drive boot it shows :
error: unknown file system
grub rescue>

I tried to format the drive using the win7 install disc but it would not do that either. (Not like I want to loose my old system. As it's not fully backed up. But I figured I had no choice.)

So then I downloaded a program called Boot-repair-disc. which I burned and ran.
first it complains it needs the internet. Which I can't seem to make happen. after it runs, it gives me text file with no instrucions, and says no changes have been made to my computer.

things it tells me:
Grub 2 (v1.97-1.98) is installed in the MBR of /dev /sda and looks at sector 2048 of the same hard drive for core.img. core.img is at this location and looks in partition 2 for boot/grub

file system :ntfs
boot sector type: windows vista/7: NTFS
boot sector info: No errors were found in the boot parameter block
operating system:
boot files:
file system: Swap
boot sector type: -
boot sector info:

drive/partition info
disk/dev/sda 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
units- sectors of 1* 512= 512 bytes)
Partition Boot start Sector end sector # of sectors id system
/dev/sda1 1 159,301,487 156,301,487 ee GPT

GUID partition table detected
partition start sector end sector # of sectors system
/dev/sda1 149,841,920 data partition (windows/linux)
/dev/sda2 6,455,296 data partition (windows/linux)


I humbly request any information that might help me get my system back. I have just moved to Europe from my home in California and I am without any of my other computers to help me solve the problem... or I would just connect the drive to a desktop and format it.
thanks in advance if anyone can give detailed instructions on how to fix my system.