Hello, im writing this because yesterday i installed Back Track 5 to my SANDISK Cruzer 8GB USB with Lili, it was working perfectly (exept the Wifi wich wouldnt start) anyway after i failed miserably i went to sleep.

The next day i booted my PC and StartX wouldnt even work.
It sends me a very long list of errors wich look like:
HTML Code:
55.942333 EXT2-FS Loop1 error ext2_lookup deleted inode referenced 384064
(like hundreds of these)
Cannot move old log file var/log/Xorg0.log to /var/log Xorg.0.log.old

Please Contact the X.ORG Foundation

ddxSigGiveup Closing Log
giving up
xinit no such file or directory errno2 unable to connect to X server
xinit no such process errno3 server error
I Decided to go to safe mode to see if it worked, what surprised me is that it worked perfectly, even better than the first time i booted it, and i even was able to have the wifi card working in seconds after installing the firmware (i spent 4 hours browsing the internet unsuccesfully before that trying to make it work)

My main problem is that i CANT reinstall bt5 currently to the usb, for some complex reasons.
Am i stuck on Debug mode? (i dont really mind that much tought) or is there a way to fix it?
And if i am, can i make it so that the backtrack options menu wont appear anymore and just go directly to backtrack debug - safe mode?

Thanx you very much everyone.