Hello experts!

I have a Acer Aspire V3-571G running 64-bit BT5 R3.
I have spent several days trying to get the wireless up and running to no avail, and therefore i must turn here for advice.

The laptop comes with a Broadcom card. I have also tried installing a TP-link WN721N usb-dongle and most recently a D-link DWA-127. None of these will install.

DWA-127 is suposed to be using the rt2800usb driver (according to http://www.wikidevi.com/wiki/D-Link_DWA-127_rev_A1). This is how i tried to get it going:

- Clean install of BT5 R3 64-bit
- I downloaded "rt2860.bin, rt2870.bin, rt3070.bin, rt3071.bin and rt3090.bin" from here -> "http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git;a=tree" and copied the files to /lib/firmware
- I then download the latest compat-wireless and installed like this:

cd /usr/src
wget http://www.orbit-lab.org/kernel/comp...-rc7-1.tar.bz2
tar jxpf compat-wireless-*
cd compat-wireless-3.6-rc7-1
make install
sudo wlunload
sudo modprobe rt2800usb

Then i connect the DWA-127 to my computer and run "iwconfig". I get "no wireless extensions".

Where am i going wrong here? It can't be three different NIC's that are bad. I am doing something wrong.

Thanks in advance