Results 1 to 3 of 3

Thread: startx, Xserver, Xorg.conf, Grub.cfg -- Help after update!

  1. #1
    Just burned their ISO
    Join Date
    Sep 2012

    Default startx, Xserver, Xorg.conf, Grub.cfg -- Help after update!

    Okay, I have a dual boot os, Win7 and Backtrack 5 R2

    I was on BT5 and was having trouble trying to run a upgrade. I finally realized that some of my sources.list was blocked, so I unblocked all the sources and the upgrade was running fine until it suddenly froze at about 90% completed and shutdown my laptop for no reason, and I had my charger in with the power cord plugged in, so I know it wasn't a battery issue or a self executed shutdown command of any sort.

    To make a very long, depressing, and sad story short, I tried to boot back into backtrack only to find out it wasn't going to happen.

    I wish I could bring the error logs into here, but I have to boot up into Win7 (sad face) just to post this issue and get help.

    I have a splash screen set up that will automatically run startx as well, after a credential login is made via the CLI - command line interface.

    I log into my account, and it boots into up my spash screen and half way through brings me back to the Cli again with a Xserver Error, similar to this:

    "Waiting for X Server to shut down
    Error setting MTRR (base 0xc0000000, size = 0x0000000, type = 1) inappropriate ioctl for device (25)
    ddxSigGiveUp: closing log"

    I then went into the memory test and booted from the command shell without networking.

    I did a search:
    locate xorg.conf

    I did a cat on my primary xorg.conf file and found out that it was completely blank! Nothing in it.

    I then realized I had another <--- like this or similar located under a usr/share/xprobe/ directory of some sort...
    I did a mv command from the file to my primary xor.conf file and it executed successfully.

    I then executed:
    nano /etc/default/grub

    edited it to read:
    GRUB_CMD_LINE_LINUX_DEFAULT="text splash vga=791" I also tried GRUB_CMD_LINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1" as well, with no success here

    I have also executed:
    rm /root/.kde/cache-root/cache-*
    rm -rf /var/tmp/kdecache-*

    Finally what I have done is this:
    dpkg-reconfigure xserver-xorg

    I believe this brought up the same xserver error as before

    I started networking:
    cd /etc/init.d/
    ./networking start

    Tried a apt-get update: Received multiple errors, can't remember as of now.
    Same thing happens with apt-get upgrade or honestly any kind of apt-*
    I recall as well having some broken libraries or sources as well

    This bugs...

    I am really going to need some help here and hope you guys can help me out, I do not want to have to reconfigure, download, install, and compile everything I download and put hours upon hours of work into.

    Additional information:
    Graphics Card: Radeon 4200 series
    OS: Backtrack 5 R2 Gnome series Ubuntu 12.0.6

    Guess I am not sure with the crash towards the end of the distro-upgrade

    I am afraid that I have tampered with so many of the .conf files and others that I may not get this machine running properly again.

    Thanks in advance,
    - Ninjex

  2. #2
    Just burned his ISO
    Join Date
    Sep 2012

    Default Re: startx, Xserver, Xorg.conf, Grub.cfg -- Help after update!

    I'm having the same issue. I'm pretty sure the startx stopped after I updated as well.
    I followed the How to make BT persisent w/ USB w/ Encryption.
    not sure if that has anything to do with it, but i'll add the info.

    After installing BT5 to my hard-drive on my laptop, I'm trying to re-install the OS from a boot disc.
    >>>startx #Isn't working for me either.

    (==) Log file: "/var/log/Xorg.0.log", Time: Mon Sep 24 .....
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d

    waiting for X server to shut down .error setting MTRR (base = 0xd00000000, size 0x100000000, type = 1) Inappropriate ioctl for device (25)
    ddxSigGiveUp: Closing log

  3. #3
    Just burned his ISO
    Join Date
    Sep 2012

    Default Re: startx, Xserver, Xorg.conf, Grub.cfg -- Help after update!

    not sure if this is in relation to this issue or not,
    but even when I install the boot disc for BT5R2 GNOME, I can't get it to boot from the external DVD-drive, even though the BIOS recognizes it.
    The Boot Disc is good, works on VM on my other computer. I understand this could be a separate issue, but thought I would add it to my notes.
    I can't just re-install an OS.

Similar Threads

  1. Why is xorg.conf blank?
    By RPORT in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 9
    Last Post: 03-10-2009, 11:47 AM
  2. changes to xorg.conf not saving on usb?
    By packetjones in forum OLD Newbie Area
    Replies: 8
    Last Post: 03-09-2009, 05:01 PM
  3. xorg.conf problems
    By Pureline in forum OLD Newbie Area
    Replies: 6
    Last Post: 07-10-2008, 06:04 AM
  4. could anyone please tell me where the xorg.conf is
    By keopsitou in forum OLD Newbie Area
    Replies: 3
    Last Post: 11-02-2007, 03:32 PM
  5. xserver-xorg-video.ilntel
    By brigante in forum OLD Newbie Area
    Replies: 0
    Last Post: 08-31-2007, 06:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts