Okay, I have a dual boot os, Win7 and Backtrack 5 R2

I was on BT5 and was having trouble trying to run a upgrade. I finally realized that some of my sources.list was blocked, so I unblocked all the sources and the upgrade was running fine until it suddenly froze at about 90% completed and shutdown my laptop for no reason, and I had my charger in with the power cord plugged in, so I know it wasn't a battery issue or a self executed shutdown command of any sort.

To make a very long, depressing, and sad story short, I tried to boot back into backtrack only to find out it wasn't going to happen.

I wish I could bring the error logs into here, but I have to boot up into Win7 (sad face) just to post this issue and get help.

I have a splash screen set up that will automatically run startx as well, after a credential login is made via the CLI - command line interface.

I log into my account, and it boots into up my spash screen and half way through brings me back to the Cli again with a Xserver Error, similar to this:

"Waiting for X Server to shut down
Error setting MTRR (base 0xc0000000, size = 0x0000000, type = 1) inappropriate ioctl for device (25)
ddxSigGiveUp: closing log"

I then went into the memory test and booted from the command shell without networking.

I did a search:
locate xorg.conf

I did a cat on my primary xorg.conf file and found out that it was completely blank! Nothing in it.

I then realized I had another xorg.conf.save.backup <--- like this or similar located under a usr/share/xprobe/ directory of some sort...
I did a mv command from the file to my primary xor.conf file and it executed successfully.

I then executed:
nano /etc/default/grub

edited it to read:
GRUB_CMD_LINE_LINUX_DEFAULT="text splash vga=791" I also tried GRUB_CMD_LINE_LINUX_DEFAULT="text splash vga=791 i915.modeset=1" as well, with no success here

I have also executed:
rm /root/.kde/cache-root/cache-*
rm -rf /var/tmp/kdecache-*

Finally what I have done is this:
dpkg-reconfigure xserver-xorg

I believe this brought up the same xserver error as before

I started networking:
cd /etc/init.d/
./networking start

Tried a apt-get update: Received multiple errors, can't remember as of now.
Same thing happens with apt-get upgrade or honestly any kind of apt-*
I recall as well having some broken libraries or sources as well

This bugs...

I am really going to need some help here and hope you guys can help me out, I do not want to have to reconfigure, download, install, and compile everything I download and put hours upon hours of work into.

Additional information:
Graphics Card: Radeon 4200 series
OS: Backtrack 5 R2 Gnome series Ubuntu 12.0.6

Guess I am not sure with the crash towards the end of the distro-upgrade

I am afraid that I have tampered with so many of the .conf files and others that I may not get this machine running properly again.

Thanks in advance,
- Ninjex