First of all I'm working with a backtrack 5 VM through parallels.

Been working on this for 14 hours straight, so I'm desperate.

I built my own ubertooth, checks out fine. flashed the bootloader onto it just fine too.

Now i'm working on flashing the bluetooth_rxtx.bin file onto it using ubertooth_dfu but I keep getting the following error:

No module named core
Traceback (most recent call last):
File "ubertooth-dfu", line 318, in <module>
         print dfu.get_status( )
NameError: name 'dfu' is not defined.
The command I use:
python ubertooth-dfu write bluetooth_rxtx.dfu
bluetooth_rxtx.dfu is in the same folder as ubertooth-dfu. I've also tried flashing .bin, .hex, and all the rest of the stuff I can find.

I have the device in DFU mode with the only method I can, bridging pins 1 and 3 with a paper clip. Seems to work just fine as everything lights up to show DFU mode.

If anyone has the SLIGHTEST idea how I might could fix this, I'd be ever so thankful. I've tried everything i can on both mac and backtrack 5 linux, seems like I've got everything but one small detail.

Thanks in advance for any and all replies!