As I was unable to find much documentation on doing this from a different partition I decided to try creating a chroot environment with a BT5r2 iso file.

I found some documentation on how to do this with BT4 at this link:

I followed these directions perfectly down this far:

mkdir -p /root/BUILD
mv bt4.iso /root/BUILD
cd /root/BUILD/
mkdir mnt
mount -o loop bt4.iso mnt/
mkdir extract-cd
rsync --exclude=/casper/filesystem.squashfs -a mnt/ extract-cd
mkdir squashfs
mount -t squashfs -o loop mnt/casper/filesystem.squashfs squashfs
mkdir edit
cp -a squashfs/* edit/
cp /etc/resolv.conf edit/etc/
cp /etc/hosts edit/etc/
cp /etc/fstab edit/etc/
mount --bind /dev/ edit/dev
chroot edit
apt-get update
apt-get upgrade
I had already gotten a bt command-line prompt, but when I ran apt-get upgrade I received this error:

Can not write log, openpty() failed (/dev/pts not mounted?)
Setting up libc-bin (2.11.1-0ubuntu7.10) ...

Can not write log, openpty() failed (/dev/pts not mounted?)
(Reading database ... 231201 files and directories currently installed.)
Preparing to replace libc6 2.11.1-0ubuntu7.8 (using .../libc6_2.11.1-0ubuntu7.10_i386.deb) ...
/var/lib/dpkg/ line 312: [: 3.3-2.slh.2-aptosid-686: integer expression expected
/var/lib/dpkg/ line 28: 3.3-2.slh.2-aptosid-686: syntax error: invalid arithmetic operator (error token is ".3-2.slh.2-aptosid-686")
dpkg: error processing /var/cache/apt/archives/libc6_2.11.1-0ubuntu7.10_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
 /bin/df: cannot read table of mounted file systems: No such file or directory
 Errors were encountered while processing:
  E: Sub-process /usr/bin/dpkg returned an error code (1)
This seemed odd as I had already mounted /dev in my previous steps.

But then I realized from the error message that the chroot session had tried to write to the OS that was not chroot-ed (Aptosid).

I confirmed this by doing a quick apt-get update|upgrade on Aptosid afterward and getting warnings about 2 packages that were not completely installed, nor uninstalled.

For those who might be wondering, I'm just wanting to run Backtrack 5 without having to reboot into my other partition or use vmware.

I need both OS's for work and education but Debian Sid seems to have a dependency conflict in it's repos at this time which is why I've came at this problem from this route.

Sorry if this should not be in the Advanced section, but as my last post went unanswered I decided to step it up a notch.

Any help, suggestions, or links will be much appreciated.