Results 1 to 2 of 2

Thread: AWUS036H not detecting networks in VirtualBox, works fine on LiveCD

  1. #1
    Just burned his ISO
    Join Date
    Jul 2012

    Default AWUS036H not detecting networks in VirtualBox, works fine on LiveCD

    Hi everyone,

    I am having an issue getting my new Alfa AWUS036H usb adapter working within virtual box. I am using:

    Host OS: Windows 7 Ultimate x64
    Guest OS: BT5R2 Gnome 64 bit

    The adapter picks up networks fine in Windows, but when I've used the USB pass through fitlers on virtual box to connect the adapter to an installed version of BT5 it's detected but doesn't pick up any networks. I've tried both my desktop OS as host (the one listed above) as well as my macbook running Lion.

    Endless searching has yielded nothing but video tutorials of people literally plugging the adapter in, putting it into monitor mode via
    airmon-ng start wlan0
    and then running
    airodump-ng mon0
    and it picks up networks right away. For me, those commands work but airodump picks up 0 networks. I've also started wicd and wicd doesn't pick up any networks either.

    I've tried installing the compat-wireless drivers as per here, but it still did not work.

    I had a BT5R2 64bit KDE livecd kicking around, so I booted off of it on my macbook and plugged in the Alfa, and it picks up networks in wicd as well as when I run airodump-ng.

    I'd really like to get this working through virtualbox, though.

    Let me know if there's any additional information I can provide. I'm pretty sure it's a problem with virtualbox, but who knows. I've been searching thoroughly for the last day and a half for a solution, but it seems no one has had a similar issue. I've tried both 32 and 64bit versions of BT5R2 with Gnome on virtualbox, as well as the 64bit version of just BT5 with gnome on virtual box. Like I said the only thing I've got working so far is the KDE64bit BT5R2 livecd on my macbook, and all I did was startx for the gui, then ran
    modprobe rtl8187
    #Pugged in adapter here#
    airmon-ng start wlan0
    airodump-ng mon0
    And it started working fine.

    Couple screenshots of my virtualbox network and usb settings: Network USB

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: AWUS036H not detecting networks in VirtualBox, works fine on LiveCD

    First, need to start wicd : /etc/init.d/wicd start

    Then : Let's see what is going on with your usb device:
    1. Type: lsusb | grep -i network
    It should show your usb wifi....Now, the first numbers that appears (0x:00.0 format) is the device ID.
    2. Type: lsusb -vvs "device ID" (vv is a doble v for very verbose)
    See at the end the driver used by kernel...This means that driver is loaded and in use. No need to load the module with modprobe since there are 2 types of drivers for the same 8187L chipset: the r8187L and the RTL8187L..One of those 2 do not work in monitor mode. So do not do that unless you know which one is the correct.

    Now, type : iwconfig (you should see the wlan0 interface). Now read all info and check the whole line 2, exactly at : Mode: Monitor or Managed. If in Monitor, you DO NOT need to switch to monitor mode. Your interface will be wlan0, no need for mon0, since it is already in monitor mode.
    But if you want to do so, use airmon-ng wlan0 start. Now the interface in monitor mode is at mon0 and NOT in wlan0...You can use the other method, which I always use:
    ifconfig wlan0 down
    macchanger --mac 00:11:22:33:44:55 wlan0 (it is much easier to remember that mac when using aireplay, belive me)
    iwconfig wlan0 mode monitor (you do not need to use it since airodump-ng starts the interface in monitor mode, but if you want to make sure is in monitor mode, do it, it wont hurt). And interface remains in wlan0 and NOT in mon0.

    Now run airodump.

Similar Threads

  1. BackTrack 5 not detecting wifi from Alfa card when running in VirtualBox or LiveCD
    By gsingh2011 in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 03-19-2012, 05:29 PM
  2. BT5 not detecting AWUS036H usb adapter in virtualbox, need help!
    By romdawg in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 07-29-2011, 07:46 PM
  3. Replies: 1
    Last Post: 11-13-2009, 01:20 PM
  4. EEE Pc, works fine with BT3?
    By alfred1234 in forum OLD BT3final Support
    Replies: 5
    Last Post: 12-05-2008, 03:05 AM
  5. BT3 liveCD - all fine probs after HDD install
    By Nanotube in forum OLD Newbie Area
    Replies: 1
    Last Post: 11-25-2008, 08:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts