Hey everyone,

it seems to me like SET is trying to connect to my Windows 7 machine with an OSX shell, I have tried this with gnome 64bit and KDE 64bit installed to the HDD, running a bootable USB, and a LiveDVD, to attack both a Win7 and XP machine with known vulnerabilities. The ou
tput I
get from the meterpreter is as follows:[*] Command shell session 1 opened ( -> at 2012-06-25 16:51:07 -0600[*] Session ID 1 ( -> processing InitialAutoRunScript 'post/osx/gather/enum_osx'

msf exploit(handler) > sh
[-] Post failed: NoMethodError undefined method `chomp' for nil:NilClass
[-] Call stack:
[-] /opt/metasploit/msf3/modules/post/osx/gather/enum_osx.rb:46:in `run'

msf exploit(handler) > sessions -i

Active sessions

Id Type Information Connection
-- ---- ----------- ----------
1 shell osx GET / HT
Host: User-Agent: Mozilla/5.0 (Windows NT 6... -> (

I have tried completely removing SET and Metasploit and re-installing both then running the updates. I have also used 2 different PC's with different hardware and still come up with the same errors. My network consists of a linksys wireless router with no restrictions or blocking of any kind and both attacker and victim on the same network. I've read through the bugs and fixes sections on this forum and haven't found anything, google is not helping either. Any help would be appreciated!