Results 1 to 2 of 2

Thread: Aircrack-ng Injection test fail

  1. #1
    Just burned his ISO
    Join Date
    May 2012

    Question Aircrack-ng Injection test fail

    Aircrack-ng Injection test, specifically the "Attack Tests" fails. (on Lenovo E420)

    I am using two different cards that both do not work correctly. I am using vanilla backtrack 5 r2. When attempting to crack WPA2, I get as far as running airodump-ng with a specified channel in attempt to get the actual handshake/find the clients(which it never finds), so I did some tests. I am posting this in effort to have someone explain what the test readouts could indicate. First here are my wireless cards(and some other bits of code from tests I have run so you can verify they are what I think they are)-

    RTL8188CE 802.11b/g/n WiFi Adapter (an external USB wireless card)
    RTL8111/8168B PCI Express Gigabit Ethernet controller (my standard internal wireless card)

    root@bt:~# lspci
    02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
    03:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)
    08:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

    root@bt:~# lshw -C network
           description: Ethernet interface
           product: RTL8111/8168B PCI Express Gigabit Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: eth0
           version: 06
           serial: f0:de:f1:75:e9:d6
           size: 10MB/s
           capacity: 1GB/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10MB/s
           resources: irq:41 ioport:5000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
           description: Wireless interface
           product: RTL8188CE 802.11b/g/n WiFi Adapter
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:08:00.0
           logical name: wlan0
           version: 01
           serial: ec:55:f9:c1:a2:bb
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=rtl8192ce driverversion=3.2.6 firmware=N/A ip= latency=0 link=yes wireless=IEEE 802.11bgn
           resources: irq:19 ioport:3000(size=256) memory:d1d00000-d1d03fff
           description: Wireless interface
           physical id: 1
           bus info: usb@2:1.2
           logical name: wlan1
           serial: 00:c0:ca:53:c2:60
           capabilities: ethernet physical wireless
           configuration: broadcast=yes driver=rtl8192cu driverversion=3.2.6 firmware=N/A link=no wireless=IEEE 802.11bgn
    Here are the tests that I run on each wireless card -

    A basic Injection Test -
    root@bt:~# aireplay-ng -9 mon1
    21:10:45  Trying broadcast probe requests...
    21:10:45  Injection is working!
    21:10:47  Found 3 APs
    21:10:47  Trying directed probe requests...
    21:10:47  58:6D:8F:F3:2E:3B - channel: 8 - 'OldRepublic'
    21:10:48  Ping (min/avg/max): 6.335ms/33.635ms/43.601ms Power: -43.11
    21:10:48  28/30:  93%
    21:10:48  58:6D:8F:F3:2E:3B - channel: 8 - 'OldRepublic-guest'
    21:10:49  Ping (min/avg/max): 23.234ms/33.972ms/52.181ms Power: -46.97
    21:10:49  30/30: 100%
    21:10:49  00:1D:7E:5E:91:D1 - channel: 6 - 'YHome'
    21:10:55   0/30:   0%
    An Attack Test (changed both cards to monitor mode)
    root@bt:~# aireplay-ng -9 -i mon1 mon0
    21:14:55  Trying broadcast probe requests...
    21:14:56  No Answer...
    21:14:56  Found 2 APs
    21:14:56  Trying directed probe requests...
    21:14:56  5E:6D:8F:F3:2E:3B - channel: 8 - 'OldRepublic-guest'
    21:15:02   0/30:   0%
    21:15:02  58:6D:8F:F3:2E:3B - channel: 8 - 'OldRepublic'
    21:15:08   0/30:   0%
    21:15:08  Trying card-to-card injection...
    21:15:13  Attack -0:           Failed
    21:15:17  Attack -1 (open):    Failed
    21:15:21  Attack -1 (psk):     Failed
    21:15:25  Attack -2/-3/-4/-6:  Failed
    21:15:29  Attack -5/-7:        Failed
    So this is where I am confused, the injection test worked yet the attack test failed. Does anyone know what the problem could be? A friend was able to get his working using a different computer running backtrack 4 (we ran the commands side by side as we are learning this stuff together )

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: Aircrack-ng Injection test fail

    I do not see your chipset listed in the aircrack-ng compatibility list. If not there, then is not supported or maybe unstable.

    You can use beini with version for rtl81xx chipset..Otherwise you need to buy a compatible chipset device.

    If you downloaded BT5 for just auditting WEp and WPA networks, please refer to google and search for beini. BT5 is much more then just WEP auditting.

    And again, please, read, get informed, before buying, this will save you headaches and waste of time.

    Best of Luck.

Similar Threads

  1. RTL8187 Chipset - Airmon-ng No AP's + injection test fail
    By dangerousgangsta in forum BackTrack 5 Bugs
    Replies: 8
    Last Post: 12-22-2011, 04:32 PM
  2. Settare i driver per aircrack + injection test
    By innerfears in forum Supporto Hardware
    Replies: 1
    Last Post: 02-05-2011, 12:16 AM
  3. Fehler beim Aircrack-ng's Injection test
    By alger2000 in forum Anfänger Ecke
    Replies: 2
    Last Post: 12-25-2010, 06:21 PM
  4. wlan0/eth0/network/dhcp Fail Fail Fail
    By DavidOfLondon in forum Beginners Forum
    Replies: 3
    Last Post: 09-01-2010, 08:51 AM
  5. Injection test
    By freebsd_man in forum OLD Newbie Area
    Replies: 5
    Last Post: 11-28-2008, 08:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts