Results 1 to 3 of 3

Thread: Alfa AWUS036NH an BT5R2 in VBOX

  1. #1
    Just burned his ISO
    Join Date
    May 2012

    Default Alfa AWUS036NH an BT5R2 in VBOX

    Alright, I've now tried 4 separate installs of BT5R2 in flavors of KDE 32 and 64bit and Gnome 32 and 64bit. All four are having the same issue with the usb wireless card.

    The OS detects the card in both iwconfig and ifconfig, the dmesg shows that the OS is loading what should be the proper driver of rt2800usb.

    The issue comes down to the fact the card is unable to detect any wireless network. Airmon-ng will even start up mon0 and the card goes into monitor mode, just not receiving any wireless networks, even in wicd.

    Any information you may need to assist me in solving this issue would be greatly appreciated.

    As troubleshooting goes for trying to solve this, I've tried the compat wireless 3.3 series drivers and had no luck with those working either, still has the same issues.

    I'm running this in 4.1.18 version of VBOX. I've heard this usb card is suppose to work out of the box and also seen that several people are having issues with it as well but in my search of the forums I've yet to find anyone with issues similar to my own.

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: Alfa AWUS036NH an BT5R2 in VBOX

    Why don't you use a CD live and see if usb card is fully functional...

    Are you using Vbox or VMware..You should download normal ISO image if using Vbox, not BT5r2 VMware version.


  3. #3
    Just burned his ISO
    Join Date
    May 2012

    Default Re: Alfa AWUS036NH an BT5R2 in VBOX

    Alright, tried the USB live CD and the card is still not functional. I will say I know the card works 100% when attached to the same machine in the native Host OS Win 7 64bit Ultimate as that is what I am posting to you from now while using the connection on the Alfa card.

    I did notice that the dmesg on the live cd added a new line(line 94):
    [     88.939970]usbcore: registered new interface driver rt2800usb
    [     94.876021] ADDRCONF (NETDEV_UP):  wlan0:  link is not ready
    Not sure if that may indicate a problem to the installed versions. I am using VBox and I used an ISO (not the VMWare) and used the built in installer to install BT5R2.

    Chipset is the 2870/3070 according to the lsusb output.
    Last edited by Bionic7112; 05-30-2012 at 02:56 PM.

Similar Threads

  1. BT5 Alfa AWUS036NH
    By Net2010 in forum BackTrack 5 Beginners Section
    Replies: 110
    Last Post: 02-18-2013, 11:49 AM
  2. BT5r2 Vbox + sslstrip + RougueAP trouble
    By satana77 in forum BackTrack 5 General Topics
    Replies: 8
    Last Post: 04-17-2012, 08:11 AM
  3. Alfa AWUS036NH
    By PaRrO in forum Angolo Wireless
    Replies: 0
    Last Post: 10-09-2010, 11:21 AM
  4. I need a help please !! ALFA AWUS036NH
    By f2666 in forum Beginners Forum
    Replies: 1
    Last Post: 07-09-2010, 07:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts