Results 1 to 3 of 3

Thread: Backtrack 5 r2 boots then won't boot

  1. #1
    Just burned his ISO
    Join Date
    Dec 2009

    Default Backtrack 5 r2 boots then won't boot

    Yes, I have searched google and the forums here for an answer. All I find are solutions that are not relevant to the question. So here I am.

    Toshiba Satellite L675 with AMD graphics (some terrible integrated junk) is what I am trying to boot on. I installed Backtrack 5 r2 to a USB drive and it boots perfectly on this laptop. However, a USB drive limits me because of it's size and various other reasons that really don't apply to the issue at hand.

    I installed from the USB to a portable usb hard drive. I did an actual install, not a USB setup on the portable drive. Booted perfectly on this laptop and ran fine for a day or so and through several reboots between backtrack and the windows 7 installed on the laptop hard drive. So everything work with this laptop.

    Now, I wanted a small 20 gig partition on the end of the partition table to encrypt. I had a linux partition, then ext part, then a 380gig fat32 and it was working fine. I resized the fat32 partition and left myself 20098 mb at the end for my encrypted partition. I did this while booted into the backtrack on the portable drive. I rebooted and all I get now is a black screen and a blinking cursor.

    I booted back to my USB drive and installed again exept this time I set up all the partitions during the install in case that was the issue. Same issue. I moved the drive to a new USB port and still a blinking cursor. I tried to reinstall grub and I get an error that there is no device to install grub to.

    I tried every grub fix I could come up with from google and linux forums and now luck. I have since installed to the portable drive in every possible way from letting it use the entire drive to just setting up linux partitions and leaving the remaining space unformatted. I have booted into windows 7 and done a safe removal of the drive just in case. Still all I have is a blinking cursor.

    I can boot to my live USB and the file system and everything looks as it should (as far as I can tell) on the portable drive, but it will not boot past the blinking cursor.

    So what now? Do I set fire to it or am I just missing something obvious?

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Debian land

    Default Re: Backtrack 5 r2 boots then won't boot

    It is a little confusing your post..Perhaps that is the reason why noone has post help....You need to be more specific as long as failure...Encrypt?..Well, it is up to you but you can be scratched off the list..

    I do not get it yet. You installed BT in a 20Gb? You had already a linux partition?..and a 380Gb fat32 partition?and you have left 20098Mb at the end?..

    Please, use fdisk -l and post results...Or use gparted and post results..This is a better way to know what you have and explain what you did before and after....


  3. #3
    Just burned his ISO
    Join Date
    Dec 2009

    Default Re: Backtrack 5 r2 boots then won't boot

    I can't post results from fdisk now- I scratched that project. I'm sorry I wasn't clear. I set up 3 partitions using gparted on a 500gig portable usb drive:
    /dev/sdc1 - 98 gig linux ext4
    /dev/sdc2 - 2 gig swap
    /dev/sdc3 - 400 gig fat32 ..... give or take

    I installed backtrack 5 r2 using sdc1 and sdc2 using the installer that came with backtrack 5- everything was good. Then I decided I wanted a 20 gig partition to encrypt and hide on the end of the drive. So I fired up gparted and resized sdc3 and created a 20gig sdc4. All was well.

    However, when I rebooted I got nothing but a black screen and a blinking cursor. I tried grub fixes and a host of other ideas but nothing worked.

    Finally I booted a live gparted disk and had a look with it. Gparted and fdisk from within the live backtrack (I installed gparted after I booted to the live backtrack) - only showed me 4 partitions sdc1 through sdc4 which are the ones I created. The live gparted disk showed 9 partitions. So clearly the issue is with the installer that comes with backtrack. Granted my installation choice was not traditional.

    I gave up on the installer on the backtrack live dvd and just installed it the old fashioned way. Now everything works. I didn't post a fix because I don't have one. All I have is a work around.

    My problem is solved. I will not do things the easy way and i will stick to what I know. This might be an issue that the devs want to look at. I see a ton of posts about backtrack booting to a black screen with only a blinking cursor. The only response those people get is links to various posts that offer no help. Clearly there is an issue with the installer and using pre-defined partitions. Those errors might be overlooked and booted through with most installations, but it seems that a great many are not working and leaving people with a dead install and no help.

    That being said, 99% of the people having this issue are probably just wanting to install backtrack so they can pretend to be zerocool or acidburn.

Similar Threads

  1. How does Backtrack 4 boots without inittab?
    By zeriab123456 in forum Beginners Forum
    Replies: 2
    Last Post: 01-14-2010, 10:40 PM
  2. Backtrack 3 on CD, boots to black screen
    By Frankie9437 in forum OLD Newbie Area
    Replies: 3
    Last Post: 08-07-2009, 09:27 PM
  3. Replies: 1
    Last Post: 01-04-2009, 02:24 PM
  4. Backtrack 3 boots from usb but freezes after startx
    By ragnaruk in forum OLD Newbie Area
    Replies: 7
    Last Post: 01-11-2008, 07:16 AM
  5. BT2 Boots to boot:
    By additude in forum OLD LiveCD Support
    Replies: 3
    Last Post: 12-04-2007, 12:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts