First of all I'd like to say that I updated my machine %100.
Second, without installing anything, its recognized as an adapter, (but the chipset is unkown). When I try to connect to a wifi network in wikc network manager, it goes through this process.1
1) Scans for a network, successfully finds several ones.
2) Disconnecting all active connections
3) Putting interface down
4) putting interface up
5) NONE: Obtaining IP address (or it will say verifying password if I am connecting to a WPA2)
6) Cisco: Obtaining IP address
7) Error: Unable to obtain IP address.

Thats what happens when is start the machine. When I try to scan for networks again, it is unable to find any networks.
Only after I reboot my backtrack(in VMware) or disconnect/reconnect my adapter will it find networks again. I figured out after I press "Disconnet Active Connections" in wicd network manager will it turn of my adapter, then make it so that my adapter can't scan again...
I tried downloading the "Network manager" nm-applet thing. That didn't work either.

I tried following this TuT, but got two errors!

After I typed:
ln -s /usr/src/linux-headers- /usr/src/linux-source-
I got an error
ln: creating symbolic link `/usr/src/linux-source-': No such file or directory

After I typed "make" I got this error:
root@bt:/usr/src/compat-wireless-2011-10-06# make
make -C /lib/modules/3.2.6/build M=/usr/src/compat-wireless-2011-10-06 modules
make[1]: Entering directory `/usr/src/linux-source-3.2.6'

WARNING: Symbol version dump /usr/src/linux-source-3.2.6/Module.symvers
is missing; modules will have no dependencies and modversions.

make[3]: *** No rule to make target `/usr/src/compat-wireless-2011-10-06/drivers/misc/eeprom/eeprom_93xx46.c', needed by `/usr/src/compat-wireless-2011-10-06/drivers/misc/eeprom/eeprom_93xx46.o'. Stop.
make[2]: *** [/usr/src/compat-wireless-2011-10-06/drivers/misc/eeprom] Error 2
make[1]: *** [_module_/usr/src/compat-wireless-2011-10-06] Error 2
make[1]: Leaving directory `/usr/src/linux-source-3.2.6'
make: *** [modules] Error 2

Can Anyone help me? Thanks