So I've recently attempted to run/install Backtrack on my Asus G74SX laptop and I'll tell you it's been one hell of a journey for the past two days.

So far I've tried to boot BT5 two different ways: USB using unetbootin, and live cd.
Both ways have failed with "invalid argument can not mount /dev/loop0

As far as the USB goes, I initially downloaded BT5 32 bit (even though I have a computer capable of 64 bit) from your website. Formatted my 8GB USB drive to FAT32 in windows NOT using quick format. Then used unetbootin and the ISO i downloaded to make the drive bootable.
Listed below is the specific error code I receive when attempting to boot from the USB drive in any mode/version of BT5

(initramfs)mount: mounting /dev/loop0 on //filesystem.squashfs failed: invalid argument can not mount /dev/loop0 (/cdrom/caspert/filesystem.squashfs) on //filesystem.squashfs

I then re-formatted the drive and tried using unetbootin to automatically download the BT5 ISO for me within the program and made the drive bootable once again.
Same exact error.

After searching the forums for post relative to my issue (and only finding one from last year that was never answered) I decided what the hell and burned the image to a DVD.

When booting from the DVD I receive the same god damn error.

I really have no idea how to fix this. Any help is appreciated. I just want to get BT5 up and running!

Oh and I know it's definitely not my ISOs cause VMware runs them just fine.