Backtrack 5 R2 Live-CD is running wicd v1.7.0. I want to update it to the latest version v1.7.2.1 from here: https://launchpad.net/wicd/+download

But it does not work. I did the following steps.

root@bt: # cd wicd-
# chmod +x setup.py
# ./setup.py configure
# ./ setup.py install

./setup.py configure gives the following output and error:

root@bt:~/wicd- ./setup.py configure
Error importing wpath.py. You can safely ignore this
message. It is probably because you haven't run python setup.py
configure yet or you are running it for the first time.
Using init file name 'wpath' is not defined
Error setting up data array. This is normal if
python setup.py configure has not yet been run.
running configure
Distro is: auto
NOTICE: Automatic distro detection found: debian, retrying with that...
Distro is: debian
lib is /usr/lib/wicd/
share is /usr/share/wicd/
etc is /etc/wicd/
scripts is /etc/wicd/scripts/
pixmaps is /usr/share/pixmaps/
images is /usr/share/pixmaps/wicd/
encryption is /etc/wicd/encryption/templates/
bin is /usr/bin/
sbin is /usr/sbin/
backends is /usr/share/wicd/backends/
daemon is /usr/share/wicd/daemon/
curses is /usr/share/wicd/curses/
gtk is /usr/share/wicd/gtk/
cli is /usr/share/wicd/cli/
networks is /var/lib/wicd/configurations/
log is /var/log/wicd/
resume is /etc/acpi/resume.d/
suspend is /etc/acpi/suspend.d/
pmutils is /usr/lib/pm-utils/sleep.d/
dbus is /etc/dbus-1/system.d/
dbus-service is /usr/share/dbus-1/system-services/
systemd is /lib/systemd/system/
logrotate is /etc/logrotate.d/
desktop is /usr/share/applications/
icons is /usr/share/icons/hicolor/
translations is /usr/share/locale/
autostart is /etc/xdg/autostart/
varlib is /var/lib/wicd/
init is /etc/init.d/
docdir is /usr/share/doc/wicd/
mandir is /usr/share/man/
kdedir is /usr/share/autostart/
python is /usr/bin/python
pidfile is /var/run/wicd/wicd.pid
initfile is init/debian/wicd
initfilename is wicd
wicdgroup is netdev
distro is debian
loggroup is adm
logperms is 0640
Found switch ('no-install-init', None, 'do not install the init file') False
Found switch ('no-install-man', None, 'do not install the man files') False
Found switch ('no-install-i18n-man', None, 'do not install the translated man files') False
Found switch ('no-install-kde', None, 'do not install the kde autostart file') True
Found switch ('no-install-acpi', None, 'do not install the suspend.d and resume.d acpi scripts') False
Found switch ('no-install-pmutils', None, 'do not install the pm-utils hooks') False
Found switch ('no-install-docs', None, 'do not install the auxiliary documentation') False
Found switch ('no-install-ncurses', None, 'do not install the ncurses client') False
Found switch ('no-install-cli', None, 'do not install the command line executable') False
Found switch ('no-install-gtk', None, 'do not install the gtk client') False
Found switch ('no-use-notifications', None, 'do not ever allow the use of libnotify notifications') False
Replacing values in template files...
Replacing values in wpath.py.in wpath.py
Replacing values in wicd=wpath.py.in wicd/wpath.py
Replacing values in scripts=wicd.in (mkdir scripts) scripts/wicd
Replacing values in scripts=wicd-gtk.in scripts/wicd-gtk
Replacing values in scripts=wicd-curses.in scripts/wicd-curses
Replacing values in scripts=wicd-client.in scripts/wicd-client
Replacing values in scripts=wicd-cli.in scripts/wicd-cli
Replacing values in other=wicd.logrotate.in other/wicd.logrotate
Replacing values in other=wicd.conf.in other/wicd.conf
Replacing values in other=WHEREAREMYFILES.in other/WHEREAREMYFILES
Replacing values in other=80-wicd-connect.sh.in other/80-wicd-connect.sh
Replacing values in other=55wicd.in other/55wicd
Replacing values in other=50-wicd-suspend.sh.in other/50-wicd-suspend.sh
Replacing values in man=wicd.8.in man/wicd.8
Replacing values in man=wicd-wireless-settings.conf.5.in man/wicd-wireless-settings.conf.5
Replacing values in man=wicd-wired-settings.conf.5.in man/wicd-wired-settings.conf.5
Replacing values in man=wicd-manager-settings.conf.5.in man/wicd-manager-settings.conf.5
Replacing values in man=wicd-curses.8.in man/wicd-curses.8
Replacing values in man=wicd-cli.8.in man/wicd-cli.8
Replacing values in man=nl=wicd.8.in man/nl/wicd.8
Replacing values in man=nl=wicd-wireless-settings.conf.5.in man/nl/wicd-wireless-settings.conf.5
Replacing values in man=nl=wicd-wired-settings.conf.5.in man/nl/wicd-wired-settings.conf.5
Replacing values in man=nl=wicd-manager-settings.conf.5.in man/nl/wicd-manager-settings.conf.5
Replacing values in man=nl=wicd-curses.8.in man/nl/wicd-curses.8
Replacing values in init=suse=wicd.in (mkdir init/suse) init/suse/wicd
Replacing values in init=slackware=rc.wicd.in (mkdir init/slackware) init/slackware/rc.wicd
Replacing values in init=redhat=wicd.in (mkdir init/redhat) init/redhat/wicd
Replacing values in init=pld=wicd.in (mkdir init/pld) init/pld/wicd
Replacing values in init=lunar=wicd.in (mkdir init/lunar) init/lunar/wicd
Replacing values in init=gentoo=wicd.in (mkdir init/gentoo) init/gentoo/wicd
Replacing values in init=default=wicd.in (mkdir init/default) init/default/wicd
Replacing values in init=debian=wicd.in (mkdir init/debian) init/debian/wicd
Replacing values in init=arch=wicd.in (mkdir init/arch) init/arch/wicd
sh: pybabel: command not found

Can anyone tell my how to install?

As work a round I tried to connect to my AP manually:


ifconfig $interface down
dhclient -r %interface
ifconfig $interface up
iwconfig $interface essid $essid
iwconfig $interface mode managed
dhclient $interface

This script works fine with no encryption. The client gets an IP via DHCP.

But now I tried with WPA2 encryption and faild again. I changed the scrip to:


echo "Installing wpasupplicant..."
aptitude install wpasupplicant
ifconfig $interface down
dhclient -r %interface
wpa_supplicant -B -W -Dwext -i wlan0 -c/etc/wpa_supplicant.conf dd
ifconfig $interface up
iwconfig $interface essid $essid
iwconfig $interface mode managed
dhclient $interface

My wlan0 interface is an Intel 4965. wpa_supplicant says that it can't be bound to driver --- mhhh? and I don't get an IP via DHCP.

Can anyone help me?

Thank you very much!