I've got two computers, a Lenovo with XP and a Sony Vaio UX with Backtrack 5. I am able to successfully use all available wireless networks with the Lenovo. I have been unable to use wireless networks with the Sony Vaio UX. I've changed configurations with WICD Network Manager and am able to authenticate to WPA2 networks, but I can't get an IP address. I have tried to manually assign an IP address with no results. I also tried installing a program called Wifi-Radar which was also "Unable to Obtain IP Address." I tried to install another program called Network Manager (v. This is where it gets complicated. While I ran the ./configure script, it returned some errors. I had to install the following packages in order to get past the ./configure:

I also had to install some package called "gudev-1.0" however I could only find a substitute package called "libgudev-1.0-0_151-12_i386.deb"
I noticed when I ran "dpkg -i [the file]" that it was a previous version from what I had installed before. I had one more package to install which was


Since I can't even connect to a wireless access point with the Vaio, I've had to use the good old sneakernet to transfer packages and manually install them one by one. After I installed the "deb" file, I went to plug in my flash drive to the Vaio but lo and behold it won't recognize the flash drive. I have two basic questions: Was the rollback of the "libgudev" software the reason for my flash drive not being recognized? Also, what is an easy and sure-proof way to connect to a wireless network?