Results 1 to 3 of 3

Thread: ath9k AR9287 Wireless Driver not reading fixed

  1. #1
    Just burned his ISO
    Join Date
    Apr 2012

    Lightbulb ath9k AR9287 Wireless Driver not reading fixed

    Here is my Driver for those who have ath9k drivers and are interested in seeing the full details:

    Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (rev 01)

    Now, for those who are still having issues with the ath9k drivers, the solution is way simpler than running patches and compiling and installing packages.

    I was furiously researching for three days until I found the solution.

    Check your Kernel version with:
    uname -a

    if it is a older Kernel i.e. 2.6+ go ahead and get a Backtrack os update

    apt-get update
    apt-get dist-upgrade

    after your os upgrades, go ahead and reebot your computer.

    You can run either of these commands:
    reboot or shutdown -r now

    After you get your computer back on go ahead and load up Backtrack and login and run the following command

    uname -a

    Make sure your Kernel has been upgraded to the latest Kernel Linux bt 3.2.6

    After that your wireless driver should be working fine!
    Some of the Kernels listed on Backtrack that they say are compatible with the ath9k drivers are not.
    If you want to be sure they will run, and you can't find the answer, the easiest and fastest solution is to just run the update.

    This may work on other wireless drivers, but I have not tested this, if you try this with another wireless driver and it works, please post it as well!

    Hope this helps those of you out there with ath9k drivers!

    best of luck,
    Cyfer Skyd
    Last edited by CyferSkyd; 04-16-2012 at 08:03 PM. Reason: Typo

  2. #2
    Member melissabubble's Avatar
    Join Date
    Aug 2011

    Default Re: ath9k AR9287 Wireless Driver not reading fixed

    I use a ath9k driver (AR9285) and upgrading to kernel 3.2.6 won't allow you to get an IP address using WEP. It also connects to it self when you using dhcp3-server after you create an AP. The fix is in kernel but upgrading to it might break some packages so Im using kernel with BT5-RC2 tools, just skipping that security patch.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2012

    Question Re: ath9k AR9287 Wireless Driver not reading fixed

    ok i have a wireless killer n 1103 (comes with alienware mx18) my
    other card is a atheros ar8151 pci-e gigabit ethernet controller ndis 6.20
    and microsfot vitual wifi miniport adapter

    now i have it working in windows i am new to backtrack and it will not pick up anything ! but i can connect to the internet ( i am using vmware 9.00 build 812388 and i have it installed on the 64 bit back trace 5-GNOME-64.iso like Ubuntu i am at a loss why this does not work i have been tol dmy wireless card is capable however i have also been told its not

    ( but why can i connect via internet "wired" and have it still not show up and not though wifi? when i type airmon-ng nothing at all shows up

    i have tested the different options of vmware and have even tried Hamachi can somebody sum this up for me

    is that the same thing as the card you listed or can i use the same drivers ?

Similar Threads

  1. patch wireless driver ath9k
    By M4cGyver in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 01-16-2012, 10:43 PM
  2. Replies: 0
    Last Post: 04-19-2010, 01:43 PM
  3. Trying to update the BT4 ath9k driver for TL-WN422G v2
    By proboscide99 in forum Beginners Forum
    Replies: 0
    Last Post: 04-17-2010, 04:24 PM
  4. how to inject with ath9k driver?
    By tasovi in forum OLD Newbie Area
    Replies: 1
    Last Post: 01-10-2010, 09:12 PM
  5. updated ath9k driver
    By custode in forum OLD BT4 Feature Requests
    Replies: 0
    Last Post: 04-14-2009, 04:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts