Results 1 to 2 of 2

Thread: Wireless Broadcom 802.11n doesn´t work propperly

  1. #1
    Just burned his ISO
    Join Date
    Apr 2012

    Question Wireless Broadcom 802.11n doesn´t work propperly

    Hi there, I´m having some issues with my wireless card... When i run the command airmon-ng, it says wlan0 unknown (I´ll show properly the message below). But anyway I´m able to put it in monitor mode, but when I run airomon-ng scan the #Data never increases (even if I send packages with aireplay)

    (I´m not an expert, just about 2 days ago I installed the BT 5 KDE, and the commands I know are limited, and those which I´ve seen in youtube).

    Here are the Reports:

    lo        no wireless extensions.
    wlan0     IEEE 802.11bgn  ESSID:"Other"  
              Mode:Managed  Frequency:2.437 GHz  Access Point: D4:XX:XX:XX:XX:XX   
              Bit Rate=72.2 Mb/s   Tx-Power=19 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=60/70  Signal level=-50 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:8   Missed beacon:0
    eth0      no wireless extensions.
    Interface       Chipset         Driver
    wlan0           Unknown         brcmsmac - [phy0]

    There you can see what I was talking about

    eth0      Link encap:Ethernet  HWaddr e8:11:32:XX:XX:XX  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    lo        Link encap:Local Loopback  
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:142 errors:0 dropped:0 overruns:0 frame:0
              TX packets:142 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:22313 (22.3 KB)  TX bytes:22313 (22.3 KB)
    dmesg | tail
    [ 1127.184887] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 1127.184900] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1127.184912] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 1127.184924] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 1127.184936] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1127.184948] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1127.264991] ieee80211 phy0: brcms_ops_config: change monitor mode: false (implement)
    [ 1127.265010] ieee80211 phy0: brcms_ops_config: change power-save mode: false (implement)
    [ 1127.269011] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
    [ 1127.270361] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    I´ve been looking everywhere and trying everything in order to solve this problem, but I couldn´t by myself... I´ve also erased the line in the blacklist where says bcm43xx (I´ve read that BT blacklisted it don´t know why), and then tried to install the drivers, but something occurred that didn´t let me do it...

    The most important, my wireless card is: Broadcom 802.11n BCM94313HMGB

    If something else is needed please let me know, and I´ll post immediately (as you can see I´m desppered jaj)
    Last edited by mgscrewu; 04-17-2012 at 07:50 AM.

  2. #2
    Just burned his ISO
    Join Date
    Feb 2011

    Default Re: Wireless Broadcom 802.11n doesn´t work propperly

    have you tried
    ifconfig wlan0 up

Similar Threads

  1. Acer Aspire 1551 Broadcom BCM43225 wireless doesn't work
    By synthevol in forum Non Working Hardware
    Replies: 4
    Last Post: 10-25-2011, 10:12 PM
  2. Getting BROADCOM Wireless to work in BackTrack!
    By stormeye in forum BackTrack Howtos
    Replies: 33
    Last Post: 04-12-2011, 06:47 AM
  3. Wireless doesn't work after apt-get upgrade
    By megamall in forum Beginners Forum
    Replies: 1
    Last Post: 08-01-2010, 04:29 PM
  4. My wireless doesn't work
    By thugz_life in forum OLD Bt4beta Non-Working Hardware
    Replies: 1
    Last Post: 06-22-2009, 10:27 AM
  5. BT3 + Wireless Network doesn't work
    By kenchi in forum OLD BT3beta General
    Replies: 7
    Last Post: 12-19-2007, 11:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts