Results 1 to 2 of 2

Thread: Wireless Card RTL8191SEvA, Trouble using Make

  1. #1
    Just burned his ISO
    Join Date
    Mar 2012

    Default Wireless Card RTL8191SEvA, Trouble using Make

    Hello Everybody,

    So I have Backtrack R1 installed on HDD on my HP G72 laptop (not sure the last part matters).

    I would post a total lspci but I don't have internet access where I am besides wifi, so I'm using another laptop here to post this. For my wireless card, lspci shows
    Network Controller: Realtek Semiconductor Co., Ltd. RTL8191SEvA Wireless LAN controller (rev 10)
    If you require anything else please ask, as the forum suggests I'm very new to backtrack.

    Anyways, I've tried to google this and I've used these links to try and install it (even after googling the error I'm about to post)

    So the error I get whenever I type in make in the terminal is this,
    /lib/modules/ no such file or directory. Stop.
    [all] Error 2
    I really don't understand what to do. I've tried looking into the /HAL/ directory for the Makefile as I saw somebody here post (lost the link to thread), but nothing was there that the post said to delete.

    Thanks for any help guys.

  2. #2
    Just burned his ISO
    Join Date
    Feb 2012

    Default Re: Wireless Card RTL8191SEvA, Trouble using Make

    Judging from that last error message in your post it would appear you are either missing the kernel headers OR you haven't created the proper symlink.

    First off, make sure you are connected to the internet when typing this command:


    After that is done type the following:

    ln -s /usr/src/linux /lib/modules/

    hit Enter and try the Make command again.

    Another solution would be to just download the newest version of Backtrack 5 R2 and see if that solves your problem without having to compile anything since the new version features a newer kernel.

Similar Threads

  1. Having trouble getting my network card running. Please help
    By vampirepsycho in forum Beginners Forum
    Replies: 4
    Last Post: 08-05-2010, 06:13 PM
  2. How to make Backtrack 3 work with a GMA 3100 card.
    By jackwalsh20 in forum OLD Newbie Area
    Replies: 0
    Last Post: 04-03-2009, 06:26 AM
  3. Replies: 1
    Last Post: 02-01-2009, 03:35 AM
  4. Can't make my wifi card to work
    By Nedad in forum OLD Newbie Area
    Replies: 2
    Last Post: 10-14-2008, 03:22 AM
  5. Atheros card trouble!
    By slaffe in forum OLD Newbie Area
    Replies: 0
    Last Post: 05-01-2008, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts