Okay I'll make this as short and simple as possible. For the past month or so I've been doing lots of research on here, other forums, and google searching for answers of the million dollar question which I still cannot find:

Can a Macbook Pro running OSX 10.5 using VMWare, VirtualBox, or Bootcamp successfully perform SSL Strips or any similar network injection with its default networking hardware?

I've came across posts that have said it only works with USB Wifi cards, while other posts have said they've been successful without mentioning anything about USB Wifi cards. I have also came across posts that have mentioned running 2 VMWares at once. Finally, I've seen posts which speak of editing etter.conf (change ec_uid and ec_gid from 65534 to 0, and also remove the comment '#' from ipchains OR iptables). I just want a final answer.

This is my current configuration and procedure in which fails when using ettercap to perform sslstripping. Maybe someone can spot something:

-Running BT5 using VirtualBox (I also have VMWare, and a windows XP Partition on my HDD but this is my procedure using VB w/ Mac OSX 10.5)

-My VirtualBox network configuration is as follows:

-Adapter 1: Enabled as NAT using Adapter Type: PCnet-FAST III

-Adapter 2: Enabled as Bridged Adapter (en0) using Adapter Type:
PCnet-FAST III with Promiscuous Mode as 'Allow All'.

-Adapter 3: Enabled as Bridged Adapter (en1) also using the same adapter as
above w/ promiscuous mode 'allow all'.

1) Inside BT, I open up Ettercap gui

2) Under options I only have 'Promisc Mode' checked

3) Sniff -> Unified Sniffing ->

-If I select eth0, I see IP Addresses that I believe are VirtualBox assigned
Therefore I will use eth1 since it is my Ethernet connection in VirtualBox
going directly into my HOME router.

4) Hosts -> Scan for hosts -> After finding my clients, Host List

5) I have seen some people say to add the router into Target 1, while others say to use Target 2 for the router . In this case, I will use Target 1 for the router ( and my own computers ethernet card as Target 2 (

6) Mitm -> Arp poisoning -> Check 'Sniff remote connections' -> OK.

The second I poison my ethernet card I lose connectivity to the internet. My router works fine as all of the other clients can still ping the internet. When I stop the attack it comes back online.

I have tried this same proccess with other computers, and cell phones on my network with the same result. Any help would greatly be appreciated. Thanks!