Results 1 to 2 of 2

Thread: Can't connect to encrypted networks

  1. #1
    Just burned his ISO
    Join Date
    Jun 2010

    Default Can't connect to encrypted networks

    I would appreciate any help. I am new to linux and have spend the last couple of days tearing my hair out on this problem.

    Firstly I have an EEE 901 dual-booting Backtrack 4 final (with persistent changes)
    Network card : RaLink RT2860

    Problem : I can't connect to my home network with encryption turned on. If change my network to unencrypted it works fine so I assume the network card is setup ok. I also know this is not a hardware problem as it works fine on same machine under Crunch Bang which I also believe is ubuntu based.

    I have tried
    WICD first....failed to authenticate : either with psk as asci or hex
    several other network manager programs (all have now been removed)

    I am now using WPA_SUPPLICANT from the command line. I have followed numerous guides to creating wpa_supplicant.conf. I've tried just the ssid and psk in asci or in luck

    Current wpa_supplicant.conf
    	pairwise=CCMP TKIP
    I tried every setting I can come across for this and everytime I get.....

    #wpa_supplicant -Dwext -i ra0 -c/ect/wpa_supplicant.conf
    ioctl[SIOCGIWSCAN] : Resource temporarily unavailable
    Trying to associate with <ROUTER MAC ADDRESS> (SSID='PlusnetWireless' freq=2412 Mhz)
    Authentication with <ROUTER MAC ADDRESS> timed out
    this keeps looping around until I hit ctrl+c when I get

    ^CCTRL-EVENT-TERMINATING - signal 2 received
    iwlist ra0 scan suggests
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : CCMP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    Some other info...
    #airmon-ng start ra0
    Found one process that could cause trouble.....................
    PID xxxxx dhclient (running on ra0)
    Interface = ra0
    Chipset = RaLink 2560 PCI
    Driver = rt2500 (monitor mode enabled)

    airodump-ng ra0 shows my network with following attributes
    however, a windows server 2008r2 machine reports
    Security type : WPA2-Personal
    Encryption Type : AES

    I have read CCMP is part of AES so is this effectively saying the same thing

    Really sorry for such a long first post. I appreciate there alot of similar posts but I have read the ones I have come across, tried what was suggested and had no luck. Hope it all makes sense as very tired at the minute. Just want to get this working. I would appreciate any suggestions, whatever they may be.

    Many thanks once again

  2. #2

    Default Re: Can't connect to encrypted networks

    Man, try to use the wicd, with the ndiswrapper driver.
    I already had a RaLink card, and I could use it very well with the ndiswrapper.


Similar Threads

  1. can connect only to some networks
    By popadom in forum OLD Newbie Area
    Replies: 2
    Last Post: 10-12-2009, 04:47 PM
  2. I can't connect to encrypted wireless networks
    By Philip2222 in forum OLD Newbie Area
    Replies: 4
    Last Post: 07-06-2009, 02:31 PM
  3. Cant connect to any networks
    By warship45 in forum OLD BT4beta Bugs and Fixes
    Replies: 16
    Last Post: 06-11-2009, 02:48 PM
  4. Cannot connect to WiFi Networks
    By Gr33n3gg in forum OLD Newbie Area
    Replies: 4
    Last Post: 10-07-2008, 12:17 PM
  5. please quick help about the wep key encrypted
    By setas in forum OLD Newbie Area
    Replies: 13
    Last Post: 11-13-2007, 01:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts