Results 1 to 10 of 19

Thread: Atheros AR9285 with ath9k driver unable to connect to internet using WEP

Threaded View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2012

    Default Atheros AR9285 with ath9k driver unable to connect to internet using WEP


    I tried posting a similar thread a few days ago but I believe it was rejected due to lack of information, wrong forum, and probably other reasons as well.

    Since then I have been doing more research on this issue and have found more information.

    I have a Samsung N150 Plus netbook, the internal wireless nic is using the Atheros AR9285 chipset and ath9k drivers. Everything works fine in BT 5 and BT 5R1. In BT 5R2, I can connect to my router with WPA2 and get out to the internet just fine, but my other router which is encrypted with WEP allows me to connect just fine but I am unable to access the internet or any other computers on the network, including the router.

    During my research of the issue I have determined that this is a known bug in the 3.2.6 kernel. There is currently a patch, which I have tried to apply and recompile the kernel but it is not very clear to me how this needs to be done and other than that I understand that there are quite a few tweaks applied to the BT kernel as it is.

    Just to be clear, I am still running the stock BT 5R2 3.2.6 kernel.

    Here is a thread on detailing the problem and seems to include a fix:


    After reading over my post I noticed that I forgot to give a couple details. All of the BackTrack versions that I have mentioned above will be the 32bit Gnome versions, although since this is an issue with the kernel I believe this will affect all versions.

    Thank you for reading this and any assistance you can provide!


    edit: I think I spoke too soon, my previous post was accepted
    Last edited by devi1; 03-12-2012 at 05:38 PM.

Similar Threads

  1. Replies: 0
    Last Post: 03-30-2011, 07:44 AM
  2. Atheros ar9285 Driver
    By mixit in forum Beginners Forum
    Replies: 28
    Last Post: 12-18-2010, 03:45 AM
  3. ATHEROS AR9285 problema driver BT3
    By calo88 in forum Supporto Hardware
    Replies: 1
    Last Post: 10-28-2010, 09:03 PM
  4. Replies: 0
    Last Post: 04-19-2010, 01:43 PM
  5. Atheros ath9k not working
    By MrOkieDokie in forum OLD Newbie Area
    Replies: 5
    Last Post: 09-07-2009, 12:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts