When i went to upgrades i saw there was available an ubuntu 10.10 which im guessing is the background of Backtrack 5 r2.
I started the update that lasted a few hours. When the installation started i followed it a bit and there were following errors

wasnt able to install rubygems1.8
libreadline-ruby was deleted and wasn't able to install a compatibile version

and allot of these
cannot open pixbuf loader module /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache doesn't exist.

After the update (which was aborted by the update not by me) i saw that when he was configuring he lost my connection
i tried connecting but i wasnt able to get the ip from the host (tried to connect via wireless)
When i tried geting in the old kernel and ubuntu i have a black screen
and when i try getting in the same ubuntu rescue version i have the following error (that keeps repeating)
Date time - DataSourceEc2.py[WARNING] time [line number/100] url error [[Errno 101] Network unreachable]

Any help so i can try to get the system up would be appreaciated .

If i can provide any usefull information please tell me so.

Thank you all in advance,