Results 1 to 2 of 2

Thread: "db_connect error" when using metasploit with back-track 5 R1

  1. #1
    Just burned his ISO
    Join Date
    Feb 2012

    Default "db_connect error" when using metasploit with back-track 5 R1

    im trying to use postgresql-8.4 which is installed of course on back track, and my issue startes when i run the command-" /etc/init.d/postgresql-8.3 start" it doesnt show any output saying that it is starting it just goes to another "root@bt~#" prompt. so then, when i run metasploit and try to issue the command "db_connect postgres:toor@" i get an error saying that db_connect failed to connect to the server , is it accepting tcp/ip connections on port 5342 etc... i have a feeling that it has something to do with postgresql not starting up right or not at all. i run the "db_services" command and it says that im using postgresql, same when i run "db_driver" says im using postgresql. but why doesnt it connect? i need advice

  2. #2
    Just burned their ISO
    Join Date
    Nov 2012

    Default Re: "db_connect error" when using metasploit with back-track 5 R1

    toor is not the password for the postgres user. I'm not sure what is, I'm running into a similar problem now.


Similar Threads

  1. Temporary fix for the "db_nmap" error In Metasploit
    By bambuka in forum BackTrack 5 Fixes
    Replies: 0
    Last Post: 09-24-2011, 01:44 PM
  2. back track 5 "recovery mode" yes video, back track 5 "normal mode" no video
    By satelitetv in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 06-16-2011, 08:23 PM
  3. Replies: 4
    Last Post: 02-24-2011, 04:52 PM
  4. Replies: 3
    Last Post: 02-16-2011, 03:47 AM
  5. Milw0rm "back on track"
    By imported_St3f@n in forum OLD Pentesting
    Replies: 0
    Last Post: 07-13-2009, 02:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts