So I am pretty new to BT5 and noticed when I try to use Airodump-ng that it would work for a couple mins then just stop picking anything up. It also did the same thing to me on BT4. Constantly using airmon-ng stop [interface] and airmon-ng start [interface] would reset it and allow me to use it once again but only for a few mins. I tried disabling many things and using airmon-ng check kill and nothing seemed to fix the problem. I run BT5 along side of windows 7 so i wondered if Windows 7 was messing with HAL. So i booted into windows 7 and disabled all ethernet adapters and only left the wireless adapters enabled. Im on a laptop so I made sure the wireless radio switch was enabled as well. Low and behold it fixed the issue! When i booted back into BT5 everything worked normally. No more hanging wireless and no more freeze-ups when using airodump-ng, wash, reaver, or aireplay-ng. Everything is kosher. The only thing i noticed is when doing this in BT4 it will not allow you to use the ethernet adapter whatsoever. However, in BT5 it does allow you to use your ethernet adapters and the internet.

This is what i did step by step:
1. Boot into win7 disabled ethernet adapters, make sure radio switch is on (laptops), reboot.
2. Boot into BT5, open wicd netowrk manager(goto BT menu then Internet)
Click on preferences. Where u see wlan0 or w/e your wifi adapter is called change it to an adapter that DOES NOT exist (i used wlan3.) to stop it from monitoring the adapter you are trying to use.
3.Lastly open a Konsole and do "airmon-ng stop wlan0" then airmon-ng check kill.

Hope this helps! It bugged the crap out of me!
Sorry if this fix was posted elsewhere I couldn't seem to find anything that resolved it.