Results 1 to 2 of 2

Thread: Pyrit with sqlite

  1. #1
    Just burned his ISO
    Join Date
    Dec 2010

    Default Pyrit with sqlite

    Hello everyone,

    i was playing around with pyrit and CUDA the past few days and generated some rainbow tables for fun. My results were stored by default under file://.
    I loaded the database with several wordlists suitable for wpa. Everything worked fine.

    I tried to create the database with sqlite-support for backing it up easier and therefore installed python-sqlalchemy and python-psychopg2.
    Now it was possible to create the sqlite-database and connect to it. But importing passwords from the same wordlists used before always stops at 20800000 lines with following error messages:

    pyrit -u sqlite:////root/pyrit/pyrit.db -i /root/wpalist.txt import_passwords
    Pyrit 0.3.1-dev (svn r280) (C) 2008-2010 Lukas Lueg
    This code is distributed under the GNU General Public License v3+
    Connecting to storage at 'sqlite:////root/pyrit/pyrit.db'...  connected.
    20800000 lines read (301814.6 lines/s)... Traceback (most recent call last):
      File "/usr/bin/pyrit", line 6, in <module>
      File "/usr/lib/python2.5/site-packages/", line 116, in initFromArgv
        func(self, **options)
      File "/usr/lib/python2.5/site-packages/", line 356, in import_passwords
      File "/usr/lib/python2.5/site-packages/cpyrit/", line 306, in store_password
        self._flush_bucket(pw_h1, pw_bucket)
      File "/usr/lib/python2.5/site-packages/cpyrit/", line 1076, in _flush_bucket
        session.add(PAW2_DBObject(pw_h1, bucket))
    AttributeError: 'Sess' object has no attribute 'add'
    A search with google ("AttributeError: 'Sess' object has no attribute 'add'" AND pyrit) gave me the following link:

    Network is coming back… « Pyrit

    In the corresponding comments to the article (scroll all the way down) someone stated, that a new version of sqlalchemy would solve the problem (quote: 0.5.6 should be fine).
    I tried to install a newer version of sqlalchemy, but it requires python >=0.9

    So, before i get a huge mess with mixing the standard repositories and my own packages .....

    Has anyone else experienced something comparable ?

    As i got several views but no comments on this post yet ... Did no one tried pyrit with sqlite or am i the only one with that kind of problem ? That would be strange, for i am using a fresh hardrive install with all my packages coming from the standard backtrack repositories. Or ist it just such a stupid error, that no one will tell me :-) ?
    It would help if someone would just state, that everything worked fine for him with no modifications at all .... i promise i will improve my command line fu then ... :-)

    Thanks !


  2. #2
    Just burned his ISO
    Join Date
    Dec 2010

    Default Re: Pyrit with sqlite


    I made a cluster (only 3machine) pyrit without own database.

    I have a stupid question for you: why do you use database? Does not enough the essid name and the wordlist.txt to create hash? What does the database include?

    Sorry my bad english.

Similar Threads

  1. sqlite and airolib-ng
    By imported_PeterPanzki in forum OLD Tutorials and Guides
    Replies: 0
    Last Post: 06-07-2008, 04:11 AM
  2. Can't create new SQLite database
    By imported_LinuxNoob in forum OLD BT3beta General
    Replies: 0
    Last Post: 04-06-2008, 11:46 AM
  3. Installing sqlite-3.4.0
    By FedorEmelianenko in forum OLD Newbie Area
    Replies: 6
    Last Post: 01-29-2008, 04:58 AM
  4. How to install sqlite ?
    By Anthony2oo5 in forum OLD Newbie Area
    Replies: 9
    Last Post: 12-27-2007, 09:36 PM
  5. SQLite update
    By dapirates1 in forum OLD Newbie Area
    Replies: 12
    Last Post: 11-15-2007, 02:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts