Hello, new to Backtrack, love the distro so far.

I have searched the forums to no avail, please direct me to the appropriate spot if this has already been answered.

I tried wireshark from the live cd and it gave an error regarding missing elf headers. The rest of the distro worked perfectly, except of course for airbase which errors on every distro I have tried, so I disregarded wireshark and figured I could get it updated/working after my HDD install. Injection with aireplay-ng works great etc.

So i performed the HDD install and am now receiving a segmentation fault error when trying to launch wireshark.

So being a good little noob I went and downloaded the latest stable release and was greeted with dependancy hell. My GTK+ needed updated, so off I go to get GTK+ most recent stable release. Turns out now I need to update cairo and glib, as well as pango.

After downloading and building all of the above, GTK+ still says my libs are out of date, so I update my path and its still not finding them.

I come to you bruised and battered seeking guidence and smack talk

Any advise?