Results 1 to 2 of 2

Thread: RTL8192E Wifi card

  1. #1
    Just burned his ISO ashio83's Avatar
    Join Date
    Jan 2011

    Wink (SOLVED) RTL8192E Wifi card Problem

    Congrats on a superb release guys. Just thought id report this in the HCL section. I have a RTL8192E wireless card and it is being reported by airmon-ng as having a RTL8187 chipset (which it doesnt) and driver in use is r8187, this is obviously wrong because i used this card in BT4 r2 no probs. Just to let you know the issue is there. This problem occurs in 64 bit Gnome and both 64 and 32 bit versions of KDE. I havnt tried 32 bit gnome but i presume the issue still exists there too.


    1) Check if your headers and source packages are up to date:
    sudo apt-get install linux-source linux-headers-`uname -r`
    2) Download Realtek r8192e driver archive from here:
    I think the latest is rtl8192e_linux_2.6.0015.1013.2010.tar.gz

    3) CD to download location and extract with:
    tar -xvjf rtl8192e_linux_2.6.0015.1013.2010.tar.gz
    4) When you installed the kernel source package in step (1) it puts an archive in /usr/src We need to extract that source archive.
    First we need to find source package version number, do so by inputting:
    dpkg -p linux-source | grep Depends
    5) When we have the source package version number, we can extract the archive in /usr/src:
    sudo tar -C /usr/src -xvjf /usr/src/linux-source-your version number.tar.bz2
    6) Now we can build and install the driver
    CD into the Realtek r8192e driver archive we downloaded in step 2.

    sudo make
    sudo -s make install
    8) Next add module to kernel:
    sudo modprobe r8192e_pci
    9) Now we need to edit the modules file. Use your favourite editor
    nano /etc/modules
    gedit /etc/modules
    kate /etc/modules
    Add this line to the bottom then save
    Reboot and all should be well.
    Mods please move this if it is now in the wrong place. Thanks.
    Last edited by ashio83; 05-13-2011 at 05:51 PM. Reason: Solved the problem

  2. #2
    Junior Member dangerousgangsta's Avatar
    Join Date
    Jul 2008

    Default Re: RTL8192E Wifi card


    I have a few question about this. When you say its working, does that mean with monitor mode + injection?

    I have also stumbled across some problems whilst following your instructions. I have an N210 with the RTL8192e chipset, BT5 is also recognising this as RTL8187.

    The part i'm having an issue on is:

    sudo apt-get install linux-source linux-headers-`uname -r`
    I get:

    linux-source is already the newest version.
    E: Couldn't find package uname -r

    tar -xvjf rtl8192e_linux_2.6.0015.1013.2010.tar.gz
    it just does not go ahead and tells me:

    bzip2. (stdin) is not a bzip2 file.
    tar: Child returning status 2
    tar: Exiting with failure status due to previous errors
    If i replace -xvjd with -xzf it goes through but when I then get too:

    sudo tar -C /usr/src -xvjf /usr/src/linux-source-your version number.tar.bz2
    which gives me the same error as mentioned above.

    I'm doing this via a LIVE BT5 USB because I want to see if it works with my netbook before doing a proper install. Is there any way you can help me? Thanks.

    (all commands are executed under root@root:~#

    Another thing, in your instructions you say to reboot, but if I do that I will lose all changes as it's a LIVE i'm testing it on, is there no way to see the results without restarting?

    UPDATE: I've also just tested the BT4-R2 and my RTL8192e card is not listed at all. iwconfig doesn't show it either. airmon-ng gives a blank display.
    Last edited by dangerousgangsta; 12-16-2011 at 09:38 PM.

Similar Threads

  1. does rtl8192e wireless card work on backtrack?
    By leeyj4951 in forum Beginners Forum
    Replies: 2
    Last Post: 02-04-2010, 08:40 AM
  2. Realtek RTL8192E Wi-Fi Card
    By slayerns in forum OLD BackTrack 4 NON working hardware
    Replies: 3
    Last Post: 01-27-2010, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts