Results 1 to 4 of 4

Thread: How to include islsm driver in BT2 ?

  1. #1
    Junior Member
    Join Date
    Jul 2007

    Default How to include islsm driver in BT2 ?

    Hi, there:

    I'm using BackTrack 2 and I have an USB Wifi adapter that when asked lsusb gives back:

    ID: 09aa:1000 Intersil Corp. Prism GT 802.11 b/g adaptor

    I have been told that this device does not use PRISM drivers, that it is "prismGT softmac" (don't know what this expression implies) and theses devices does not use prism54 driver but islsm driver (that is not included with backtrack).

    Then, question is: Is there an easy way/procedure for a new comer to the Linux world for updating BT2 once the liveCd is booted (the same way there is a procedure for updating the ipw2200 driver) and be able to work with such device?

    Anyone knows if once included the islsm driver and the device recognized I will be able to work with the aircrack-ng suite with it?

    Thanks !

  2. #2
    Member imported_blackfoot's Avatar
    Join Date
    Jun 2007

    Default prism gt

    Soft MAC is not known to be stable yet under Linux. It is marginal but workable under the Windows operating system. Depending on requirements you might obtain a different card/device.

    As BT is a Live distribution it resides in RAM with optional calls to CD. Thus, it can be modified at any time. However, you may be better installing it on hard disk if your updates are frequent.
    Lux sit

  3. #3
    Moderator theprez98's Avatar
    Join Date
    Jan 2010


    Buy a better supported card.

  4. #4
    Junior Member
    Join Date
    Jul 2007

    Default islsm and Backtrack

    theprez98: thanks for your advice... but one of the things I have to do is to check and test different cards... and this one is one of them

    blackfoot: I know, I know, but anyway I will have to do the update first time, and this is still my question.

    General: I was able to find the prosm54 and islsm urls and looked over there, but I have several problems:

    1.- I downloaded the FreeBSD version of the driver and tried to install it. MAKE and MAKE Install both gave to me same error: makefile:3: *** unsupported separator STOP. As I'm not very knowledgeable of Linux, I'm not able to correct it.

    2.- I went to the islsm url and looked over it and to the forum... Unfortunately what I found was a very very very complicate procedure of installation, talking about TLA and many other things I read and heard about for the first time. Too complicated for me.

    Then, again my question, Isn't any simple way for a newbe for installing this kind of driver as was developped for the IPW2200 one?

    Thanks so much and regards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts