I'm experimenting sniffing my home network, which is my AP, a windows wireless laptop connected to the AP, and backtrack on a different laptop. The wireless connection is unsecured.

I'm using a Hawking HWUG-1 as my wireless card with backtrack. I enter into Kismet & monitor mode and start a pcap dump. I then browse to google and other sites on the windows laptop. I open the pcap dump in wireshark, but the only thing that is captured are Beacons between the windows computer and AP. No data packets are captured.

I also tried using wireshark to capture on the wlan0mon created by kismet, but again, only the beacons are captured. Additionally, I tried capturing traffic after establishing a connection with the AP from the BT box, but again, no data packets are captured.

Is this an issue with the drivers?

lsmod gives the following wifi related lines:

Module Used By
rt73usb 0
rt2x00usb rt73usb, rt2500usb
rt2x00lib rt73usb, rt2500usb
ipw2100 0
mac80211 rt2x00usb, rt2x00lib
lib80211 libipw

is there a conflict between ipw2100 and rt73, or is the Hawking just not using the correct drivers? If it is a driver issue, how do I correct it?