Results 1 to 2 of 2

Thread: Geforce 9800GT max resolution of 640x480

  1. #1
    Just burned his ISO
    Join Date
    Nov 2011

    Default Geforce 9800GT max resolution of 640x480

    To start I've been having issues with my 9800 gt on both ubuntu 11.10 and backtrack 5 kernel version

    I have my computer set up to an LG HD tv at the moment until I get a replacement monitor and the max resoultion I'm able to get is 640x480 while the tv has a native resolution of 1600x1200. I've tried everything I can think of and can find online to get it to display 1600x1200 including xrandr (cvt --addmode --output --newmode etc..) and modifying my xorg.conf file. I am new to having to mess with the xorg.conf file and I removed all changes I made to post my clean conf file here. I'm using a dvi adaptder to a vga cable into the tv. Windows displays the resolution with no problems but I believe the issue is because the tv doesn't give an edid. Below are copies of my xorg.conf file and xorg.0.log file.

    If the nvidia-bug-report is needed I will post that as well.

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 285.05.09  (  Fri Sep 23 17:55:57 PDT 2011
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    Section "Files"
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
    xorg.0.log will be posted in the second post.

    Also if it's any help I followed the below steps to disable nouveau and install the nvidia drivers

    cd /usr/src/linux
    cp -rf incklude/generated/* include/linux
    echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
    update-initramfs -u
    sh /usr/<nvidia driver>.run --kernel-source-path /usr/src/linux-source-
    Thanks in advance

    Well I've mostly gotten it figured out, I haven't yet gotten it to 1600x1200 however I have gotten it to 1280x1024 which does allow me to see everything on my screen. I tried for several hours of reading through documentation/reinstalling backtrack and starting fresh and I finally figured it out. In this case running "nvidia-xconfig" was a HUGE problem, after I ran X -configure I made several modifications to my xorg.conf file and finally made some progress. Below is my new xorg.conf file.

    Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync 31.5 - 70.0
            VertRefresh 50 - 160
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "SWcursor"               # [<bool>]
            #Option     "HWcursor"               # [<bool>]
            #Option     "NoAccel"                # [<bool>]
            #Option     "ShadowFB"               # [<bool>]
            #Option     "VideoKey"               # <i>
            #Option     "EXAPixmaps"             # [<bool>]
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "G92 [GeForce 9800 GT]"
        BusID       "PCI:3:0:0"
        Option      "UseEDID" "False"
    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth 24
            Modes "1600x1200" "1280x1024" "1024x768"
    Last edited by g0tmi1k; 11-07-2011 at 04:00 PM. Reason: Merged

  2. #2
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010

    Default Re: Geforce 9800GT max resolution of 640x480

    Have you installed the drivers for your graphics card?

Similar Threads

  1. [Video Geforce 7200gs] - Geforce no BackTrack 4
    By SDEscobar in forum Suporte Hardware
    Replies: 2
    Last Post: 07-25-2010, 12:50 AM
  2. pyrit and geforce benchmarks
    By imported_etech9 in forum OLD Pentesting
    Replies: 6
    Last Post: 01-10-2010, 08:32 AM
  3. Problems with GeForce FX Go5200
    By Ign0rE in forum OLD Newbie Area
    Replies: 0
    Last Post: 10-14-2007, 11:38 PM
  4. BT2 Live and GeForce Go 7600
    By NaZirCon in forum OLD Newbie Area
    Replies: 1
    Last Post: 09-12-2007, 02:43 PM
  5. Replies: 0
    Last Post: 04-12-2007, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts