Results 1 to 3 of 3

Thread: airmon-ng problem

  1. #1
    Just burned his ISO
    Join Date
    Aug 2011

    Default airmon-ng problem

    Hello, i've used backtrack before but now on my new laptop after i've installed the new BT5-R1 x64 KDE i wasn't able to start airmon-ng nor for my integrated wlan card witch is "Intel(R) Centrino(R) Wireless-N 100 BGN" chipset, nor my USB Alpha AWUS036H, drivers are ok, tried different combinations like wlan0 on & wlan1 off and then to start airmon-ng, but with no use, the Problem is that after "airmon-ng start wlan1" (in this case it's my alpha) it detects the card but doesn't return to shell, it just hangs forever, sometimes activates it sometimes no but never returns to shell prompt. i would really need some assistance
    root@bt:~# airmon-ng start wlan1
    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    PID    Name
    1436    dhclient
    1453    dhclient3
    Process with PID 1436 (dhclient) is running on interface wlan0
    Process with PID 1453 (dhclient3) is running on interface wlan0
    Interface      Chipset        Driver
    wlan1          Realtek RTL8187L        rtl8187 - [phy0]
                                    (monitor mode enabled on mon0)

  2. #2
    Just burned his ISO
    Join Date
    Nov 2011

    Smile Re: airmon-ng problem

    I had the same problem on my laptop.

    Airmon-ng would enable monitor mode but hangs shortly after. Try this to fix it: rmmod iwlagn

    Then run airmon-ng and it should work properly. Type modprobe iwlagn to re-enable once mon0 is active.

    Hope this helps, it worked for me :-)

  3. #3
    Just burned his ISO
    Join Date
    Oct 2011
    San Diego, CA

    Default Re: airmon-ng problem

    Try running
    airmon-ng check kill
    airmon-ng start wlan1
    If that doesn't work try forcing the card into an enabled state(copied from the wiki):
    root@bt:~# rmmod rtl8187
    root@bt:~# rfkill block all
    root@bt:~# rfkill unblock all
    root@bt:~# modprobe rtl8187
    root@bt:~# rfkill unblock all
    root@bt:~# ifconfig wlan0 up

Similar Threads

  1. BT5 airmon-ng problem
    By KennyB in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 05-31-2011, 08:54 PM
  2. Problem with airmon-ng with BT5 on HD
    By SamiOmer in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 05-30-2011, 11:28 AM
  3. airmon-ng problem
    By l0gm31n in forum Beginners Forum
    Replies: 2
    Last Post: 05-31-2010, 07:03 PM
  4. airmon-ng problem =(
    By 1ceCold in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-19-2009, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts