Hi all,

In this thread are some instruction for newbies to just do it. (well it won't let me post url's yet... so here is the last part of the url here: showthread.php?t=7348

I did not go for the whole sha-bang and mess with X. I did just the steps to get a new kernel in place. My reasons were the scrollwheel. I have those M$ Bluetooth kb and mouse. I needed to add the bluez patch to make it work.
It does. My new kernel has almost all of the M$ keyboard buttons firing in xev, the music play, stop, vol+/vol-/mute, etc... even some of the special buttons like Mail Web/Home are firing events now. And of course my wheel works now too! I can't believe how many years I lived without one of these things.

Now the bad news... when I startx I come to a new message...
Sound server informational message:
Error while initializing the sound driver:device: 
default can't be opened for playback (No such device)
The sound server will continue, 
using the null output device.
I did not change the .config before compiling.
Here is my question 1.
1. Am I supposed to add sound for my particular card in make menuconfig?

lspci -v | grep audio reports:

00:08.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

So the kernel sees the hardware.
I didn't really have to setup anything when I did the hd install.
So I go and look in /dev/ for any sound files dsp etc... nothing there.
It's a udev kernel, right? In /dev/.udev/ I find 2 dirs, ./failed/ and ./db/
Okay, maybe I should find a "gotcha" in the failed directory so I go in there and look. Looks like udev has a big list of failed devices with timestamps around when I did the make. But a Google of "/dev/.udev/failed" leads nowhere.

Ok, now this looks serious... back to square one. I did notice at the top of the /usr/src are some other things like alsa and aufs and squashfs.

Here is what I think is my next question.
2. Am I supposed to rebuild those too?

Here is what I did in the rebuild from /usr/src/linux
bt linux # patch -E -p1 < ../patch-2.6.20-mh1
patching file drivers/bluetooth/bcm203x.c
patching file drivers/bluetooth/bfusb.c
patching file drivers/bluetooth/bt3c_cs.c
patching file Makefile
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.rej
This was just expecting a blank EXTRAVERSION = line so 
the patch could add "-mh1" to it, so I felt I could ignore 
this error and keep using the makefile already present 
patching file net/bluetooth/hci_core.c
patching file net/bluetooth/hidp/core.c
patching file net/bluetooth/hidp/hidp.h
patching file net/bluetooth/hidp/Kconfig
patching file net/bluetooth/hidp/sock.c

make oldconfig
make dep
make clean
make bzImage
make modules
make modules_dep
Ends with this:
if [ -r System.map -a -x /sbin/depmod ]; then /sbin/depmod -ae -F System.map 2.6.20-BT-PwnSauce-NOSMP; fi

Here I wound up with a
/usr/src/linux/arch/i386/boot/bzImage 3,209,192 bytes
and a /usr/src/linux/System.map 1,099,733 bytes.

Okay, so I copy those to /boot/longAssNamesToShowWhatTheyAre and symlink System.map to the real System.map file.

But wait, there is a file there named just "map". It is alot smaller, and I look inside and it looks nothing like the system.map file so I just leave that there.
It's 204,288 bytes long.

Adjust my grub menu.lst on another drive so I don't have to mess with lilo,
and boot up.

Great my mouse works, but now my sound doesn't. Even when I boot using the old kernel, I get the same error. Bummer.