Ladies & Gents,

Operating System: Back|Track5 r1
Box: Toshiba NB255-N250
Updates: Fully up to date via: apt-get update && apt-get dist-upgrade

I have recently run into a huge problem. After I had finished my script QuickSet I decided to do a demonstration for some fellow co-workers and ran into an error with the script. To follow along with my steps and what I did please grab a copy. By using the script you will speed up the debugging process since it is all automated, this will hopefully save you time
svn checkout quickset
I am going to list the steps I have taken and in the order in which I took them. The end state of the problem is a segmentation fault within airbase-ng; I'm listing the steps I took so that you can narrow that out of your solutions if you have one. I am hoping that someone on this forum has the answer. If you respond to this post, I ask that you please post cohesive thoughts so that a solution is announced, not just needless jabber. Thank you for your time.

1) Airbase-NG is crashing during extended periods of usage. There are a lot of variables to consider with this bug: nmap, ettercap, dhcp3-server, etc...

2) I first chose to eliminate xterm as a factor by changing the script to the following on the airbase-ng launch line:
airbase-ng -c $sac -e "$SSID" $pii &
I did this in the hopes that it would yield an error message while still allowing the script to continue; hence the ampersand. I had previously tried a variety of methods to evoke an error message, but was unsuccessful; evidently airbase-ng doesn't like to issue them out with regards to the at0 interface

3) I waited a little bit for at0 to not exist anymore, and then issued <crtl+c> within the script. The idea worked and I was given the following as output:
 ./ line 1:  1866 Segmentation fault      airbase-ng -c $sac -e "$SSID" $pii
4) I rewrote the airbase-ng and dhcp server part of the script so that i could launch them seperate and cancel DHCP out as a possible error cause. The most recent steps I have taken to narrow down the problem are:

# I used the same wireless card for both the internet connected NIC and external.  One might think this would be a problem, but I tried it with different cards and the same end result.  For testing purposes feel free and unhindered to use the same card
1) Wireless NIC           set to wlan0
4) Monitor Mode NIC       set to mon0
I then chose 8 and proceeded.

At the main menu I chose: 5) Routing Features

At Routing Features I chose: 2) Wireless Vaccuum

At Soft AP Parameters: I left everything defaulted except for AutoLaunch of the DHCP server, that I set to: No
# Setting AutoLaunch to no simply launches the AP and reverts back to the Routing Features menu...

At Method Selection I chose: 2) bullzeye--> Responds only to the specified ESSID
Roughly 3 minutes after creation, the at0 interface dies due to a segmentation fault.

5) My next step will be to try this on Lucid Lynx since it is roughly the same (Except for the kernel). I hope to be able to try this tonight and report back tommorow.