Results 1 to 1 of 1

Thread: Nvidia installation issue

  1. #1
    Just burned his ISO
    Join Date
    Oct 2011

    Default Nvidia installation issue


    Like so many I tried to install the Nvidia drivers and failed along the way. I will try to be as complete as possible, but don't hesitate to react if I'm leaving important information out.

    So first things first, my host computer specs :

    ASUS K93S
    18.4-inch 1920 x 1080 LED-backlight display
    intel core i7 2630qm 2ghz
    1GB NVIDIA GeForce GT 540M graphics card
    16GB DDR3 RAM

    Different steps I took :

    1. Driver download

    I downloaded the corresponding driver at this site. Filling in the form resulted in the download of

    2. Driver installation

    I installed the driver without a problem by using the command "sh"

    3. Startx attempt 1

    Ran startx and got the error that no devices were connected. This was apparantly due to another internal vga card that was set as primary card.

    Altered the xorg.conf file with the line BusID "PCI:1:0:0" (which fixed the problem)

    4. Startx attempt 2

    Ran startx and got the error that no displays were connected to the graphical card and resulted in the error message "Screen(s) found, but none have a usable configuration".

    Tried to fix is with altering modes, resolutions, without succes. After a while a came across this link which made me believe that for some reason the software could not detect the current EDID

    5. Created EDID file

    ran the command "get-edid > testedid" and checked the content by using the command "parse-edid < testedid" (see results later in this post).

    Altered the xorg.conf with following lines in the device section :

    Option "ConnectedMonitor" "DFP-0"
    Option "CustomEDID" "DFP-0:/etc/X11/testedid"

    6. Startx attempt 3 (wel in reality it was actualy more or less attempt 876 )

    Ran startx and got a black screen. The /var/log/Xorg.0.log (see later in this post) shows no real errors for as far as I can see.

    7. Current situation

    I guess I'm pretty stuck for the moment so any help would be appreciated. At this point I have no clue on how to fix this, so I guess it is time for a cold beer (maybe tomorrow I will see the light (although I doubt it)).

    Additional information :

    root@bt:/etc/X11# lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1)
    root@bt:/etc/X11# parse-edid < testedid
    parse-edid: parse-edid version 2.0.0
    parse-edid: EDID checksum passed.

    # EDID version 1 revision 3
    Section "Monitor"
    # Block type: 2:0 3:fe
    # Block type: 2:0 3:fe
    # Block type: 2:0 3:fe
    Identifier "CMO:0718"
    VendorName "CMO"
    ModelName "CMO:0718"
    # Block type: 2:0 3:fe
    # Block type: 2:0 3:fe
    # Block type: 2:0 3:fe
    # DPMS capabilities: Active off:no Suspend:no Standby:no

    Mode "1920x1080" # vfreq 59.999Hz, hfreq 66.659kHz
    DotClock 138.650000
    HTimings 1920 1968 2000 2080
    VTimings 1080 1083 1088 1111
    Flags "-HSync" "-VSync"
    # Block type: 2:0 3:fe
    # Block type: 2:0 3:fe
    # Block type: 2:0 3:fe
    root@bt:/etc/X11# cat xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 280.13 ( Wed Jul 27 17:15:58 PDT 2011

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"

    Section "Files"

    Section "InputDevice"
    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"

    Section "InputDevice"
    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BusID "PCI:1:0:0"
    Option "ConnectedMonitor" "DFP-0"
    Option "CustomEDID" "DFP-0:/etc/X11/testedid"

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24

    I hope this will give somebody an insight into what is going on.

    Kind regards,



    I clearly needed a drink yesterday (not noticing the fallback to the default vesa drivers )).

    The command "lspci -nn @ grep VGA" gave me an identifier of 10de:0df4 which is nowhere listed in /usr/share/xserver-xorg/pci/*.ids

    Don't know yet why, but will try to figure this out tomorrow.

    If you have any thoughts, just let me know (cause I can use the help).

    To be continued ...
    Last edited by g0tmi1k; 10-07-2011 at 09:23 AM. Reason: Merged

Similar Threads

  1. Problems with NVIDIA GT250 Installation
    By made2nv in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 08-31-2011, 02:06 PM
  2. Cuda issue with Nvidia 9400 GT
    By sylvestor2002 in forum BackTrack Bugs
    Replies: 8
    Last Post: 09-14-2010, 08:18 PM
  3. compiz, nvidia, Black screen issue
    By BigMac in forum OLD Newbie Area
    Replies: 2
    Last Post: 08-18-2009, 07:21 AM
  4. Nvidia driver installation problem.
    By technocool in forum OLD LiveCD Support
    Replies: 1
    Last Post: 02-01-2008, 04:06 PM
  5. USB-HDD Installation Issue
    By imported_l1nuxant_ee in forum OLD Newbie Area
    Replies: 14
    Last Post: 09-13-2007, 12:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts