Results 1 to 1 of 1

Thread: AWUS036H won't get IP but connects to network through Backtrack...

  1. #1
    Just burned his ISO
    Join Date
    Oct 2011

    Default AWUS036H won't get IP but connects to network through Backtrack...

    I know this sort of bridging between the actual NIC and Backtrack but I was wondering if someone could help me out with this.

    I have managed to get the built-in wireless on my laptop working properly with Backtrack and now I was going to use my Alpha Networks USB nic with Backtrack. I setup an 'open' network and it works for other computers getting an IP and connecting to the internet. I can also connect using the built-in wireless. However, the Alpha networks one doesn't get an IP like it's supposed to.

    When I run the 'iwconfig wlan1 essid "test" it connects and I can see the MAC of the AP, etc. However, it doesn't get the IP from the DHCP. Does anyone have any ideas about what might be preventing it? All of the other things seem okay and I didn't have to mess with the NIC to get it to plug and play. It just doesn't seem to get the IP so it can get out.

    I also can't seem to find a way to totally disable the built-in nic as well. I ran 'ifconfig wlan0 down' and it shuts off, but then when I try to use the Alpha one it comes back on and gets an IP and starts working again.

    Sorry, new to all of this....

    may have been because I didn't boot up with it plugged in. I just put it in after BT was already loaded. Seems to have made a difference after I restarted it and then it came back up because I could get the monitoring going and was capturing packets with Wireshark using that interface. After I re-installed the driver for the built-in NIC that's working better too and is going up and down properly with the ifconfig.
    Last edited by g0tmi1k; 10-06-2011 at 07:40 AM. Reason: Merged

Similar Threads

  1. How to have airmon-ng log any station that connects to an AP?
    By sniff in forum BackTrack 5 General Topics
    Replies: 1
    Last Post: 09-26-2011, 12:28 AM
  2. alfa network AWUs036H with backtrack 4 not working
    By rolandah in forum Beginners Forum
    Replies: 0
    Last Post: 11-20-2010, 03:42 PM
  3. Eth0 connects to router but does not connect to Internet
    By imported_MadHatter in forum OLD Newbie Area
    Replies: 5
    Last Post: 01-14-2010, 02:54 PM
  4. AR9285 wifi card just connects on boot proccess
    By haxple in forum OLD BackTrack 4 General Support
    Replies: 0
    Last Post: 01-12-2010, 05:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts