Results 1 to 4 of 4

Thread: No screen found on CD Boot

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Jul 2007

    Unhappy No screen found on CD Boot


    I am new to this forum and BT2. Could someone help me please - I have tried searching and cannot find an appropriate answer on this thread.

    When I start Startx on the HP desktop it comes up with a fatal error - cannot find screen - no matching VESA Modes.

    I have swapped to a Dell screen and get the same problem.

    I have run the CD from my HP laptop without any problems.

    In checking for this error message I found that they had a bug reported regarding this:

    Which says that there is a bug in the X-org distribution and that an updated version was released to fix it. Which version is BT2 running?

    The version I have downloaded is BT2Final in March this year.

    Does anyone have a solution for how to fix this please? I would like to install BT2 on this computers HD but can't get in to do it!

  2. #2
    Just burned his ISO
    Join Date
    Jul 2007

    Cool vesa mode

    Hey Doodleflip, hope this will help.
    When you boot the LiveCD and at the boot prompt, type:

    /boot/vmlinuz max_loop=255 initrd=/boot/initrd.gz init=linuxrc load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=10000 root=/dev/ram0 rw press enter

    The above should boot you to the login (text).
    Type: root
    Password: toor

    You still won't have X yet, at least I didn't until I modified my bootloader.

    I use grub and it shakes out like this:

    Title=BackTrack Linux
    root (hd0,6)
    kernel /boot/vmlinuz ro root=/dev/hda7 vga=0x317 noapic acpi=off apm=power-off vga=791

    The above kernel's parameters are all on ONE line!
    hda7 is my partition, change it to yours.

    In lilo, I believe it would be something lihe:

    image = /boot/vmlinuz
    label = BackTrack Linux
    root = /dev/hda2 (or your root patition)
    append="vga=0x317 noapic acpi=off apm=power-off vga=791"

    This works for me, for root and users. Happy hunting

  3. #3
    Just burned his ISO
    Join Date
    Jul 2007


    Ta very muchly, will give it a try today.

  4. #4
    Junior Member
    Join Date
    Jul 2007


    Have you tried "xconf" too?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts