Results 1 to 4 of 4

Thread: AR9485 ath9k BT5R1 Acer Aspire 4739Z No WIFI

  1. #1
    Just burned his ISO
    Join Date
    Feb 2010

    Default AR9485 ath9k BT5R1 Acer Aspire 4739Z No WIFI

    Hi Guys , first congrats and thanks you for the good works , i am a fan and user since a few years.
    I just got this new lap from acer a Aspire 4739Z running BT5R1 and the wifi is not working , it work under win7

    i try to re install the compat ath9k driver falllowing a similar case on ubuntu
    but it seems that im doing something wrong kernel , header wise .
    any help would be greatly appreciated.

    root@bt:~/compat-wireless-2011-11-22# make
    /root/compat-wireless-2011-11-22/ "WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m."
    make -C /lib/modules/ M=/root/compat-wireless-2011-11-22 modules
    make: *** /lib/modules/ No such file or directory. Stop.
    make: *** [modules] Error 2

    root@bt:~/compat-wireless-2011-11-22# lspci | grep AR
    01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
    02:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
    root@bt:~/compat-wireless-2011-11-22# lsmod | grep ath9k
    ath9k 76473 0
    mac80211 255996 1 ath9k
    ath9k_common 2466 1 ath9k
    ath9k_hw 305324 2 ath9k,ath9k_common
    ath 13577 2 ath9k,ath9k_hw
    cfg80211 153414 3 ath9k,mac80211,ath
    root@bt:~/compat-wireless-2011-11-22# dmesg | grep ath
    [ 2.959839] device-mapper: multipath: version 1.3.0 loaded
    [ 2.982671] device-mapper: multipath round-robin: version 1.0.0 loaded
    [ 12.651865] ath9k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 12.651878] ath9k 0000:02:00.0: setting latency timer to 64
    [ 12.659608] ath: EEPROM regdomain: 0x6c
    [ 12.659610] ath: EEPROM indicates we should expect a direct regpair map
    [ 12.659612] ath: invalid regulatory domain/country code 0x6c
    [ 12.659613] ath: Invalid EEPROM contents
    [ 12.659634] ath9k 0000:02:00.0: Failed to initialize device
    [ 12.659807] ath9k 0000:02:00.0: PCI INT A disabled
    [ 12.659814] ath9k: probe of 0000:02:00.0 failed with error -22

  2. #2
    Just burned his ISO
    Join Date
    Feb 2012

    Default Re: AR9485 ath9k BT5R1 Acer Aspire 4739Z No WIFI

    I recently purchased an Acer Aspire One 722 which also uses the AR9485 Wifi card. The card works great in windows 7 but when I boot into Backtrack I am also having the problem of it not turning on, when I do a lspci it shows

    07:00.0 Network controller: Atheros Communications Inc. AR9485 Wirelss Adapter (rev 01)

    but under ifconfig it only shows

    eth0 and lo

    there is no wan0

    iwconfig shows

    lo no wireles extensions

    eth0 no wireless extensions

    the wifi light is off and the function key will not turn it on, it does not have a hardware switch just a software switch, there is no option in bios to turn the card on or off. If anyone could help me to get the wifi working I would be eternally gratefull

  3. #3
    Just burned his ISO
    Join Date
    May 2011

    Default Re: AR9485 ath9k BT5R1 Acer Aspire 4739Z No WIFI

    I also have the Acer Aspire One 722 with the same wifi card. I am running Gnome 64 bit BT5 R1. This is how I fixed it.

    First you need to fix potential wifi conflicts and lockups

    Press F2 on boot to enter BIOS setup.
    Enable "Network Boot" then make "Network Boot" the first boot device in BIOS.
    Press F10 to save changes and boot up.
    Once booted then blacklist acer-wmi in /etc/modprobe.d/blacklist.conf.

    If you do not do this it can cause your computer to lockup when you use your wifi card and
    you will have to power down your computer to get past the lockup.

    Next open terminal and issue the following commands to compile and install new drivers for
    your wifi card. This will take 30-45 minutes so be patient.

    ln -s /usr/src/linux /lib/modules/
    cd /usr/src/
    tar jxpf compat-wireless-2011-07-14.tar.bz2
    tar xpf 2.6.39.patches.tar
    cd /usr/src/patches
    cd /usr/src/compat-wireless-2011-07-14
    patch -p1 < ../patches/channel-negative-one-maxim.patch
    patch -p1 < ../patches/mac80211-2.6.29-fix-tx-ctl-no-ack-retry-count.patch
    patch -p1 < ../patches/mac80211.compat08082009.wl_frag+ack_v1.patch
    ./scripts/driver-select ath9k
    make && make install
    make wlunload

    Once you reboot your wifi card will respond.

    Here is a fix for your audio if it isn't working and a fix for the headphone jack and the

    Navigate to System>Preferences>Startup Applications...
    Click add, then name the startup application, then under command type /usr/bin/pulseaudio

    Next open terminal and issue the following commands:

    apt-get install dkms
    dpkg -i alsa-hda-dkms-acer3830tg_0.1_all.deb

    After this logout and reboot.

    This patch solves the audio problem on 722. There are however, two caveats for this. First,
    external microphone still isn't working, and second, if internal microphone still isn't
    working, you'll need to go to Sound preferences/Input and mute and then unmute microphone (to
    enable internal microphone, in Sound Preferences/Hardware "Internal Audio" must be selected,
    and "Analog Stereo Duplex" profile. On input tab, "Internal microphone" connector should be
    selected, and Input volume should be adjusted to about 100%)

    Hope this helps

  4. #4
    Just burned his ISO
    Join Date
    Feb 2012

    Default Re: AR9485 ath9k BT5R1 Acer Aspire 4739Z No WIFI

    Worked like a charm thanks!!!!

Similar Threads

  1. wifi led for acer aspire one zg5
    By linuxbman in forum OLD Newbie Area
    Replies: 4
    Last Post: 01-27-2010, 11:12 AM
  2. Acer aspire one wifi BT3
    By computer_dude in forum OLD Newbie Area
    Replies: 4
    Last Post: 11-07-2009, 06:09 PM
  3. Acer aspire 4730z WiFi not working
    By anonymoususer in forum OLD BT3final Support
    Replies: 0
    Last Post: 03-31-2009, 07:16 PM
  4. intel wifi 5100 driver? acer aspire 5930g
    By defus in forum OLD Newbie Area
    Replies: 3
    Last Post: 02-26-2009, 04:22 PM
  5. Acer Aspire One A150AB Wifi Chipset?
    By Puntogirl in forum OLD Newbie Area
    Replies: 8
    Last Post: 01-04-2009, 05:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts