Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: How to: Compile a new Kernel & Install Xorg 7.2

  1. #11
    Junior Member
    Join Date
    Jul 2007

    Default Recompiling

    When I execute the following code as per the guide...

    cp /boot/config-`uname -r` ./.config
    I am told it cannot find that file. This will screw me right because instead of loading my current config and allowing me to make small adjustments, I will need to set all of the options from scratch.

    All I am trying to do is make the sound on my notebook work, and from what i can gather, recompiling the kernel for 2.6.22 is the only way to make tihs happen, and even then I remain skeptical.

    So if that file is missing, how can I snapshot my current config so I don't have to ground up my kernel config, which I am sure will result in disaster. :P
    "Linux is user-friendly. It's just very selective about who its friends are."

    "Linux users swear by their OS, and Windows users swear at their OS."

  2. #12
    Just burned his ISO
    Join Date
    Jul 2007


    BT2 is installed to my hd. Mine already had a .config file there, which I assumed it was the file used to make BT2. You should have one there too. I did follow his advice to a certain degree, and made the backup in /boot.

    cp /usr/src/linux/.config /boot/config-`uname -r`

    I rebuilt mine with a bluetooth patch from bluez, to get my keyboard to work. Now it works better than it did in windows XP. It's an MS bluetooth keyboard!

    Are you sure you need a new kernel?

  3. #13
    Join Date
    Aug 2007

    Default Xorg 7.2 and ati proprietary

    Thank you for the guide!

    But has anyone succesfully installed xorg 7.2 with ati proprietary drivers 8.40.xx? The driver build fails every time with errors in firegl-something (I know this isn´t ati or xorg support forum, so just asking)..

    Thanks for any info,

    Learn to live, but live to learn, eh?

  4. #14
    Junior Member
    Join Date
    Jul 2007


    i just tried to renew my Kernal i used these 2 version but with no success 2.6.22 and and every time i reboot i got this message :

    Kernal panic not syncing :VFS unable to mount root fs on unkbown-block (8,5)

    and the system hangs up .

    how can i load my old kernal ??

  5. #15
    Just burned his ISO
    Join Date
    Oct 2006


    Is there anyone who can rewrite the xorg update in newbaneeze. I have followed the directions but i was having a problem with my install looking for librares that diddnt exist. It was looking for the old libraries. I have reviewed my process but i cant seem to see exactly where i went wrong. sorry i cant post the exact error because i have already reinstalled BT2 and will try again.

    this would be a good video tut. I know some people just say to wait for backtrack 3 but I would really like to know how to do this. a tut from a fresh install would help new people like me who get confused when the "git" command doesnt work
    For everything lost there is something gained. For everything gained there is something lost

  6. #16
    Just burned his ISO
    Join Date
    Mar 2006


    Hi all,
    in the part of stay actual kernel config, cp does't work in bt3, thats why are in bt2 tutorials... but i can make it work on bt3 too:
    use it after make simbolic link :
    USE IT:
    zcat /proc/config.gz > /usr/src/linux/.config INSTEAD OF cp /boot/linux-`uname-r` /usr/src/linux/.config

    Bye all,

  7. #17
    Just burned his ISO
    Join Date
    Mar 2006


    and sorry for revive the topic....

  8. #18
    Just burned his ISO
    Join Date
    Apr 2008


    maybe i didint see well but i wonder about the part you said about if you have the same chipset, what chipset are you talking about

  9. #19
    Junior Member
    Join Date
    Feb 2008

    Default no such a file

    i did the following but when i get to /usr/src/linux/Makefile it said no such a file

    => `ChangeLog-'
    Connecting to||:21... connected.
    Logging in as anonymous ... Logged in!
    ==> SYST ... done. ==> PWD ... done.
    ==> TYPE I ... done. ==> CWD /pub/linux/kernel/v2.6 ... done.
    ==> PASV ... done. ==> RETR ChangeLog- ... done.
    Length: 2,691 (2.6K) (unauthoritative)

    100%[====================================>] 2,691 --.--K/s

    19:26:09 (2.29 MB/s) - `ChangeLog-' saved [2691]

    bt src # then i change it like it is in tutorial
    boot = /dev/sda
    # message = /boot/boot_message.txt
    timeout = 600
    # Linux bootable partition config begins
    image = /boot/vmlinuz.old
    root = /dev/sda4
    label = oldkernel
    # Linux bootable partition config ends

    # windows bootable partition config begins
    other = /dev/sda1
    label = WindowsXP
    table = /dev/sda
    bt ~ # /usr/src/linux/Makefile
    -bash: /usr/src/linux/Makefile: No such file or directory
    bt ~ #

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts