Results 1 to 2 of 2

Thread: Unable to load BT5 GUI

  1. #1
    Just burned his ISO
    Join Date
    Sep 2011

    Default Unable to load BT5 GUI

    Thread Title: Unable to load BT5 GUI

    I am new to BackTrack and am simply trying to load into the BT5 GUI from a dvd. I downloaded the 64-bit BT5 R1 KDE ISO and checked the hash MD5, which checked out fine. I then burned the ISO to a dvd using roxio creater on slow burn speed for accuracy. I can successfully boot into the disc, the first screen simply says "Boot:", where I press enter to start the boot process. The next screen asks which variant of backtrack to start (text, stealth, etc). I have tested text, stealth, and safe mode and all of them end with a screen with a black background and white text saying what is being loaded. Here is the error:

    Error Message
    ---[end trace d8fb19e5bc4adc20]---
    [drm: radeon_ttm_backend_bind] *ERROR* failed to bind 2025 pages at 0x00000000
    radeon 0000:02:00.0: object_init failed for (8294400, 0x00000002)
    [drm: radeon_gem_object_create] *ERROR* Failed to allocate GEM object (8294400, 2, 4096, -22)
    Failed to allocate:
    size: 8294400
    allignment: 0 bytes
    domains: 2

    How I have tried to resolve the issue:

    I have also tried using 64-bit BT5 (non-R1) KDE ISO, in addition to the 64-bit BT5 (non-R1) GNOME ISO; both MD5's were good and burned to a dvd. After having similar issues across the board, I thought maybe it was an issue with a hardware incompatibility. I unplugged all peripherals from the laptop (external mouse/keyboard/monitors/headset/usb hub/ethernet), and still experienced the same issue. I did some more searching online and found that other people will also having issues with the radeon series of graphics cards, and found this as a potential solution:

    Press tab on 'text' on the BT5 selection screen.
    /casper/vmlinuz file=/cdrom/preseed/custom.seed boot=casper initrd=casper/initrd.gz text splash vga=791--
    /casper/vmlinuz file=/cdrom/preseed/custom.seed boot=casper initrd=casper/initrd.gz text splash vga=791 radeon.modeset=0

    Once I added "radeon.modeset=0" the GUI would start to initialize. I would see the red BT5 background and the mouse cursor would be visible/functional. In the center of the screen was foreign characters (Chinese/Japanese/IDK), and nothing else would load. After approximately 20-30seconds the screen would go blank and hang for minutes until I turned off the computer.

    System Specs (Dell Studio XPS 1645):
    64-bit Windows 7 SP1
    8GB RAM
    Intel i7 Q820 1.73 GHz (3.06 w/ turbo boost)
    AMD Radeon HD 5700M
    Intel Centrino Advanced-N 6250 AGN Wireless

    Please let me know if there is anymore information I can provide and I am looking forward to any help I can get. Thanks ahead of time and I can't wait to get this working. BT5 looks like some amazing software!

  2. #2
    Senior Member
    Join Date
    Jan 2010

    Default Re: Unable to load BT5 GUI

    i absolutely understand the reason why some pentesters often will vehemently choose using a closed disk cd-r or dvd-r for a 'live distro". nothing additional is writable to the booted media.
    it is a sort of "clean room" thought process. and it makes absolute sense for such users to go that route.

    you,however; should payload the bootable os onto a persistent or non persistent usb pendrive and call it a day. imho. burned discs are subject to scratches in the physical surface, burner/ram under-runs, defective media, etc. Any failed delivery to a pendrive is a non-cost issue. you just redeliver the image to the pendrive like nothing ever happened. make the pendrive bootable in BIOS and you are off to the races.

Similar Threads

  1. unable to load dvd on laptop bt4final
    By blasboy in forum Beginners Forum
    Replies: 4
    Last Post: 08-23-2010, 09:09 AM
  2. Unable to load BT3 beta
    By bluezodiac in forum OLD Newbie Area
    Replies: 4
    Last Post: 04-24-2009, 04:46 AM
  3. unable to load sqlite3
    By coolabhijits in forum OLD BT3final Bugs and Fixes
    Replies: 3
    Last Post: 04-21-2009, 09:50 PM
  4. PLS cannot startx.....unable to load required base modules
    By habznation in forum OLD Newbie Area
    Replies: 17
    Last Post: 12-11-2008, 10:19 PM
  5. Unable to load BT3 on Compaq
    By YearZirO in forum OLD BT3beta
    Replies: 2
    Last Post: 06-05-2008, 08:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts