I have Backtrack 5 R1 kde HDD install. i have a Atheros AR5B97 with ath9k driver innstalled(have tried ath5k also). injection and packet capturing works fine.
but i can not for the love of god connect to my own wifi ap with wicd, i always get the error "wrong password" i am 100% sure it is the correct key (and i have chosen the correct encryption method in the settings in wicd for the accesspoint.). i have tried the fix for wicd d-bus error, i have tried to uninstalling wicd and innstalling network-manager,(and setting dhcp on the interface in the interfaces file and in the konsoll as described in the howto`s) i have also tried to connect with the konsoll but no luck.
I have searched the net and backtrack forums and wiki and howto`s. i also tried other ap without encryption(open ap) but still no connection.

I have a small suspicion that the probem may be that the essid has a turkish letter in it
(it displays wrong in wicd and in the consoll "TERRADES\xDDR1" but should be TERRADESYR1 with tyrkish "Y".

I hope someone can help me. sorry for my bad english.