Hello. This is my first post to the forum.

Recently I tried to upgrade the version of Wireshark in Backtrack 2. Having gone through trial and error, I would like to share how I got it working. Since I am not an advanced Linux user, please excuse any misuse of technical jargon. Backtrack 2 comes with version .99.4. The new version as of this posting is .99.5.

I am doing this on a 'Real' installation.

Anyway, I downloaded the source from the wireshark website to my desktop, extracted using the 'tar -xf' command. There are a few 'Read Me' files, which was kind of confusing at first. The instructions said the default compile options should work. Yet for me they didn't.

Using the default ./configure command, I noticed that Wireshark wasn't even set to build. And upon issuing the 'make' command, it compiled for about ten minutes, and then I got errors when it got to the 'agentx' plugin. After re-reading the help options, and some guesswork I got it to compile using these options:

./configure -disable-gtktest -disable-usr-local



make install

Previously I had tried to use one of the Wireshark packages from slacky.eu. I am not sure if I did something wrong though. I used the pkgtool to install the .99.5 version; yet the 'About Wireshark' still showed .99.4.

That's it for now. Hope you all have a good day.