Results 1 to 4 of 4

Thread: Metasploit n900

  1. #1
    Just burned his ISO
    Join Date
    Jan 2011

    Cool Metasploit n900

    Im trying to install metasploit on my n900 and i followed these instructions to the letter but when i start metaploit i am faced with this error any ideas how to solve this or whats gone wrong ...

    home/user/MyDocs # ruby1.8 /home/user/msf3/msfconsole -L
    [-] ***
    [-] * WARNING: No database support: LoadError no such file to load -- rubygems
    [-] ***
    < metasploit >
           \   ,__,
            \  (oo)____
               (__)    )\
                  ||--|| *
           =[ metasploit v3.3.4-dev [core:3.3 api:1.0]
    + -- --=[ 492 exploits - 0 auxiliary
    + -- --=[ 192 payloads - 23 encoders - 8 nops
    msf >
    after reinstalling the ruby gems i am now faced with this error

     WARNING: No database support: LoadError no such file to load -- active_record
    is this never ending now i have this error any one have any ideas at all ??

    ARNING: No database support: RuntimeError ruby lib version (1.8.5) doesn't match executable version (1.8.7)
    what am i missing ere

    many thanks

  2. #2
    Just burned his ISO
    Join Date
    Aug 2007

    Default Re: Metasploit n900

    You may want to check out the n900 image that the pwnie express guys have published:

  3. #3
    Just burned his ISO
    Join Date
    Aug 2010

    Default Re: Metasploit n900

    From the error, seems rubygems is missing. I would suggest you follow up the tutorial on hxxp:// . I managed to install metasploit and other pentesting tools on the n900 but they were not as seamless. Updating metasploit on the n900 via svn was a problem because you have to look for a debian image to chroot into and perform the update. I would recomend you try the pwnimage from pwine express. It really rocks. You can see some tools it has come with on the pwine site hxxp:// and also I have some few screenshots on my blog on the pwnimage .hxxp:// I have had no issues with it so far.

  4. #4
    Just burned his ISO
    Join Date
    Jan 2011

    Cool Re: Metasploit n900

    Finally solved the issue its been ages but got there in the end , heres how for anybody

    i install ruby gems from source , then latest metasploit fromwork .

    apt-get install ruby1.8 irb1.8 rdoc1.8 libopenssl-ruby1.8 subversion
    then it works a treat apart from being out of date ...

    tried svn update and i get segmentation fault ...


Similar Threads

  1. nokia n900
    By vjeko71 in forum BackTrack 5 ARM topics
    Replies: 0
    Last Post: 05-20-2011, 09:53 PM
  2. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  3. NeoPwn for nokia n900
    By lordplagueis in forum Beginners Forum
    Replies: 11
    Last Post: 03-22-2011, 05:51 PM
  4. Backtrack on Nokia n900
    By enduser in forum OLD Newbie Area
    Replies: 9
    Last Post: 01-15-2010, 09:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts