Hello, I have a HDD install of 32 bit Backtrack 5 with GNOME.
I have been trying to build a rainbowtable out of a wordlist using the program genmpk. I know that the wordlist contains my password, however when i build it into a rainbowtable and use that with cowpatty, it says that the password isnt in the file. I know that the issue isnt with the cap file because I provided the handshake myself, and I was able to crack the password in about 20 seconds with that same wordlist using aircrack-ng. What I believe the problem to be is that the rainbowtable isnt getting completely built. The wordlist i'm using has about 110,000 passwords. When I build it into the rainbowtable using the following command:

root@bt:~# genpmk -f root/password.lst -d root/rainbowtable -s essid

genpmk 1.1 - WPA-PSK precomputation attack. <jwright@hasborg.com>
File /root/rainbowtable does not exist, creating.
key no. 1000: qualities
(not going to include them all, but i'll include some)
key no. 10000: snowball8
key no. 20000: Sanders9
key no. 30000: Dolphins
key no. 37000: Missioning

37130 passphrases tested in 307.10 seconds:  120.91 passphrases/second
There end up being far fewer passwords in the rainbowtable than are in the wordlist. I know how many passwords are in the wordlist because i opened it in gedit, scrolled to the bottom, and read that i was one line 107462 with one password per line.

Here's what happens when i use it:

root@bt:~# cowpatty -r packets.cap -d /root/rainbowtable -s essid

cowpatty 4.6 - WPA-PSK dictionary attack. <jwright@hasborg.com>

Collected all necessary data to mount crack against WPA/PSK passphrase.
Starting dictionary attack.  Please be patient.
key no. 10000: snowball8
key no. 20000: Sanders9
key no. 30000: Dolphins
fread: Success
Unable to identify the PSK from the dictionary file. Try expanding your
passphrase list, and double-check the SSID.  Sorry it didn't work out.

I did check to see if my disk was full (it could happen) and I also tried rebuilding the table twice, but with the same result as the first time. I do not think that the program is skipping passwords, as the 10000, 20000, and 30000th passwords are the same. Rather, I think that it stops building the list. I have tried building other lists as well with similar results, although how much of the wordlist it computes vaires by the wordlist (it doesnt stop at around 37000 every time).
I havnt seen anyone else with this problem, and i've looked. I dont think this is how genpmk is supposed to function, although I guess i could be mistaken. Any thoughts? I'll try anything you think will work.