Hardware --> Toshiba NB255 Netbook (GMA 3150 Integrated Graphics Chipset)
O/S --> BT5R1 Gnome

Yesterday I came across something that really bothered me, so I worked and worked on it, and I have implemented a good hack to workaround the problem. I'm hoping that perhaps the Devs can address this issue in depth and fix it so that my workaround is not needed. Attached you will find a picture of the kernel panic, I've no experience with kernel develoment and thus, I have no clue what the codes mean. I took some of my cues on where to start from reading the codes, but it was a shot in the dark none the less.

A little background on the subject; with BT4R2 on the same netbook, it would not support 1024x600 graphics. There is a very nice workaround to this problem located here:915 Chipset Fix. The thread itself is a little confusing to follow because people are so afraid to experiment and kept asking the poor guy questions, but in the end what worked for me was installing the hack and then placing this line in my rc.local file
915resolution 38 1024 600

Now that you have the background in mind and can follow my thoughts... Let me describe the current issue and what I did as a workaround hack to prevent the panic.

I have a Western Digital 500GB USB external harddrive. It's one of the newer ones with USB 3.0 support, as well it is the newer model in the fact that the profiterring gluttons who create the thing have soldered the usb adapter chipset directly to the harddrive itself (Harddrive makers started doing this about 2 years ago to prevent people from buying the portable harddrives, gutting them, and using them as cheap alternatives to the more pricey "laptop" harddrives....) I would attach other pertinent serial numbers and such, but the thing is very scratched up so I cannot provide that. Perhaps this is limited to this batch of HDs...I don't know.

I was doing some work in BT yesterday and had inserted the external harddrive mentioned above. To my surprise the harddrive was automounted. Prior to moving to the Gnome version I had used the other option of KDE (KDE is WAY slow in booting compared to Gnome on my box). Now, KDE would pop up a box telling me a device had been inserted, but it would not automount it.

FYI, Gnome in it's default configuration automounts harddrives, opens a folder to the drive, and also places an icon linking to the mounted device on the desktop.

Now then, I did what I had to do with the harddrive and decided to remove it via a right click on the desktop icon and click "safely remove drive", I believe there was also an option for eject, but I don't remember (I figure they are essentially the same thing, and the system should prevent me from doing anything to crazy).

!!!KABOOM!!! Kernel Panic! =(

In line 7 of this attachment: Attachment 771 you will see autoremove_wake_function. I took this and started doing some research via google and such. I came across the following post: Within the post, you'll see where they added in i915.modeset=1 to the grub commands (Perhaps, since I had to use a 915resolution fix for BT4r2, maybe it had something to do with the panic). I did what they suggested, and tried to recreate the panic. It actually did prevent the panic the first time, but after it "ejected" the drive, it remounted itself seconds later....When I tried to eject a second time, the very same kernel panic happened. Back to square one I was.

From there, I decided to see what I could do about the "automount" problem, I figured maybe it had something to do with Gnome automounting drives. I found the solution to prevent automounting here: Now, by default BT5R1(Gnome) does not come with gconf-editor built-in. It does come with gconftool-2, which is essentially the same thing but text based and damn confusing to use. So, i installed gconf-editor via apt-get and then started to mess with stuff. I will post the keys which I changed tonight, I am at work and forgot to email them so I could post them. Either way, the keys that I changed were in---> /root/.gconf/apps/nautilus/preferences and /root/.gconf/apps/nautilus/desktop. I modified it by setting the value of the keys to false that did: 1) Automount external devices, 2) Open folder automatically when a drive is mounted, 3) Place Icon of mounted folder on desktop.

From there I saved, rebooted, and started experimenting some more.

Keep in mind, if you open a GUI folder to look at the contents of anything in the file system there will still be a way to "gui-eject" a device. I didn't do this because I knew it would just lead down the same road.

Now, I know what some of you are already going to ask, so I will answer that lest it be asked and clog up this thread. How do I mount a drive if there is no gui!?!?!? Easy. Open a terminal and do
mkdir foo
fdisk -l

See the different drives and such?  Pick what you want to mount, in my case it was /dev/sda1

now do:
mount /dev/sda1 foo

p00f yer drive is now mounted to where foo is located at.

Okay, so how do we umount? Two ways... 1) umount /dev/sda1 -or- 2) umount ~/foo
Now that the question that would be asked is out of the way, let me answer the next question. Did using this solve the problem? YES!
Using the commandline to mount/unmount the same harddrive worked liked a charm. NO kernel Panic. This is not the ideal way to handle the situation, I would definately prefer to have the option of using the GUIs but if this is what I gotta do, it's what I gotta do.

Devs... Any ideas on the Panic and the cause? I'm guessing something to do with the way Gnome interfaces on the GUI side of the house with reference to mount/dismount??

I made a discovery today. I found a computer. Wait a second, this is cool. It does what I want it to. If it makes a mistake, it's because I screwed it up. Not because it doesn't like me... Or feels threatened by me.. Or thinks I'm a smart ass..