Results 1 to 2 of 2

Thread: WICD wont connect after R1 update, VM problems

  1. #1
    Just burned his ISO
    Join Date
    May 2011

    Default WICD wont connect after R1 update, VM problems

    Running BT5-gnome-64 as VM in Virtualbox on an OSX Lion host....Prior to the apt-get update to R1 everything was working great.....The update trashed my VM and after cleaning things up, WICD will not connect to anything....

    When I rebooted after the update, my entire VM was reverted back to "original" settings. Even after reinstalling the guest additions. Screen resolution was bad, lost my bridged network adapter (en1 as eth0), lost my USB filters, and my shared folders. It was like I had created a new VM and everything was reverted to default. I had to reconfigure Virtualbox, and got all of my settings restored.

    When attempting to connect using my AWUS036H adapter, WICD gave its usual "could not connect to d-bus" error, which I promptly fixed. However WICD WILL NOT validate any passwords and connect to any AP's....I have tried 3 different AP's, using WEP, WPA, and WPA2...Ive tried WEP as HEX and passphrase...Ive tried WPA as passphrase and PSK...Cannot connect to anything...

    Several times, WICD reports no wireless networks at all, as if the Alfa isnt connected....The virtualbox status bar indicates the Alfa is connected, and the Alfa itself had a working green light...WICD acts like it isnt there...WICD does however show my "wired" (host en1-eth0) connection and I can connect through that...I just cant connect through my USB Alfa....

    The aircrack suite seems to work fine with the Alfa...I can inject and deauth anything, so I dont think this is a driver problem...Its something with WICD....

    Im open to guidance and suggestions for solving this..Thanx guys...

  2. #2
    Just burned his ISO
    Join Date
    May 2011

    Default Re: WICD wont connect after R1 update, VM problems

    To add some info on the issue:

    This is most definitely related to the drivers, and how WICD handles them in the R1 release....Upon opening WICD, it will scan for and locate wireless AP's. When I attempt to connect, WICD goes through its normal process: Disconnecting active connections>putting interface down>putting interface up>validating authentication....Then I immediately get "Bad password". What I have found is when WICD takes the interface down, it stops the driver...So when WICD reports "putting interface up", the card has been turned off and no driver is loaded....Its basically "unplugging" the card....I figured this out after getting the SIOCFFLAGS error in airmon....

    I followed the wiki on rt2800usb drivers and ran all of this:
     root@bt:~# ln -s /usr/src/linux /lib/modules/
    root@bt:~# cd/usr/src/
    root@bt:~# wget
    root@bt:~# tar jxpf compat-wireless-2011-07-14.tar.bz2  
    root@bt:~# wget
    root@bt:~# tar xpf 2.6.39.patches.tar
    root@bt:~# cd compat-wireless-2011-07-14 
    root@bt:~# patch -p1 < ../patches/mac80211-2.6.29-fix-tx-ctl-no-ack-retry-count.patch 
    root@bt:~# patch -p1 < ../patches/mac80211.compat08082009.wl_frag+ack_v1.patch 
    root@bt:~# patch -p1 < ../patches/zd1211rw-2.6.28.patch 
    root@bt:~# patch -p1 < ../patches/ipw2200-inject.2.6.36.patch 
    root@bt:~# make 
    root@bt:~# make install
    root@bt:~# reboot

    New drivers didnt solve my issue, and actually created the "Fixed Channel -1" issue in airodump....I havent found any solution to these issues yet, so I used Time Machine to revert back to my original BT5 install....It works FLAWLESSLY....Im going to install R1 as a second VM and hopefully a solution can be found for all of the issues with the Alfa in R1....

Similar Threads

  1. Help! Wifi wont connect
    By TRSchmidtty in forum Beginners Forum
    Replies: 4
    Last Post: 10-15-2010, 04:51 PM
  2. Wicd Wont start
    By xanifer in forum Beginners Forum
    Replies: 4
    Last Post: 08-02-2010, 01:13 AM
  3. Wont connect to WPA?
    By zuric in forum OLD Newbie Area
    Replies: 3
    Last Post: 04-30-2008, 09:11 AM
  4. card wont connect
    By wallsballs in forum OLD Newbie Area
    Replies: 5
    Last Post: 07-25-2007, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts